IMX8MP stuck in recovery mode

Hardware used:
Model: Toradex Verdin iMX8M Plus Quad 4GB Wi-Fi / BT IT V1.0B
Carrier: Toradex Verdin Development Board V1.1A

As stated in the title my iMX8MP is currently stuck in recovery mode. After powering on it goes straight into recovery mode, I get no console output at all.
When I use the recovery-windows.bat it boots into Toradex Easy Installer fine.
I have tried to install every possible image without success. I even tried to erase the flash.
But as soon as I reboot the board the it goes into recovery mode.

Please, advice.

Hello Jochen,

Are you aware that in recovery mode the Toradex easy installer is not flashed put just loaded into RAM?
So when you use the recovery script and it boots fine into the Toradex Easy installer you can then select to flash the latest version.
You should not erase the flash since you will also erase module specific init data.

Best Regards,


yes I’m aware that running recovery-windows.bat only loads the the Easy Installer into RAM.
What I meant with

was, that the Easy Installer provided me with four different images to flash onto the module(TorizonCore, Easy Installer, Yocto Full, Yocto Minimal - I think, can’t currently check).
I tried all four of them. The installation procedure is straight forward. You double click an image, get a security question, wait for the progressbar to complete and at the end you get asked if you want to shutdown the system or reboot it.
The next time I power up the module I get nothing on the console. No boot messages at all.

About the ‘erase the flash’. I’ll keep it in mind, when my module is working again. It was a last ditch effort to get the module running again.

Best regards

OK, so did you got console output when you ran the Toradex easy Installer?