imx8 won't go into recovery mode

Hi

I am unable to get the board into recovery mode. I have shortened the pins as per the photo ( https://developer.toradex.com/knowledge-base/load-toradex-easy-installer#tab-apalis-imx8 ) but it won’t go into recovery.

I shorten the pins, turn power on, wait more than 6 seconds and let go. Every time it goes through normal boot up and shows the Portainer.io screen. The red reset LED will come on and after 4-5 seconds always turns off.

I have tried holding it for shorter amount of time (2-3 s), longer amount of time (20 seconds). I have power cycled the board several times (not shorting the pins) with everything disconnected. I have also tried with everything disconnected and trying to get into recovery.

Setup
DVI video connection
USB-RS232 connection (X29)
USB OTG (X50)
USB mouse and keyboard

Any ideas, what can I try?

Thank you

Peter

Could you try to erase flash uisng U_boot commands:

> mmc dev 0 1
> mmc erase 0 100

Thank you for your reply. I was able to erase the flash using the commands you gave which put the system into recovery mode. I was able to successfully upload Easy Installer and start with a clean OS.

Thanks again.

Peter

Glad your problem was solved. Thank you for the update.