iMX8 stops at starting kernel

Hello,

I installed TorizonCore 5.0.0 on an iMX8 but I can not boot it.
This is the serial output:

U-Boot 2020.04-5.0.0-devel+git.ec6e8627026b (Jan 01 1970 - 00:00:00 +0000)

CPU:   NXP i.MX8QM RevB A53 at 1200 MHz

DRAM:  4 GiB
MMC:   FSL_SDHC: 0, FSL_SDHC: 1, FSL_SDHC: 2
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Model: Toradex Apalis iMX8 QuadMax 4GB Wi-Fi / BT IT V1.1B, Serial# 06738462

 BuildInfo: 
  - SCFW 732e719a, SECO-FW 376e3c15, IMX-MKIMAGE 6745ccdc, ATF 
  - U-Boot 2020.04-5.0.0-devel+git.ec6e8627026b 

switch to partitions #0, OK
mmc0(part 0) is current device
flash target is MMC:0
Net:   eth0: ethernet@5b040000
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot:  0 
MMC: no card present
MMC: no card present
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr
3216 bytes read in 17 ms (184.6 KiB/s)
## Executing script at 83100000
565 bytes read in 18 ms (30.3 KiB/s)
Loading HDMI firmware...
102464 bytes read in 20 ms (4.9 MiB/s)
Loading hdp firmware from 0x0000000087000000 offset 0x0000000000002000
Loading hdp firmware Complete
161050 bytes read in 32 ms (4.8 MiB/s)
14 bytes read in 12 ms (1000 Bytes/s)
33331712 bytes read in 752 ms (42.3 MiB/s)
9168969 bytes read in 230 ms (38 MiB/s)
## Flattened Device Tree blob at 83000000
   Booting using the fdt blob at 0x83000000
   Loading Device Tree to 00000000fd603000, end 00000000fd64dfff ... OK

Starting kernel ...

I do not get any output via hdmi.

Do you have an idea howto solve this problem? Thank you for your help!

Hi @Flo,

Unfortunately the TorizonCore 5 is still unstable, as it does not have an official release.
So you may face issues like this.

Just for an internal feedback for my side, which release of TorizonCore 5 are you using?

Either way, I’d suggest you to use TorizonCore 4 for the moment.

Best regards,
André Curvello

Hi @andrecurvello.tx,

thank you for your reply, I am not sure which version it was exactly (I am working on a different project atm) but I guess the latest nightly version from that day. Before I tried it with TorizonCore 5 I tried it with TorizonCore 4 but I didn’t even get any serial output.

Best regards,
Flo

Hi @Flo,

In addition to what André has said about trying TorizonCore 4 since TorizonCore 5 is still a work in progress. You should also note the known issue listed here: https://developer.toradex.com/software/toradex-easy-installer/release-details?view=all&key=TEI-649

You may also be affected by this issue in this specific case. In short, for the time being make sure to use recent builds of our Easy Installer tool when flashing software on the i.MX8. For more details please see here: https://developer.toradex.com/software/toradex-easy-installer#beta-release

Best Regards,
Jeremias

Hi @Flo and @jeremias.tx ,

Currently the nightly builds of Toradex Easy Installer are having the TEI-649 fix.
You can download the latest nightly here: https://artifacts.toradex.com/ui/repos/tree/General/tezi-oe-prerelease-frankfurt%2Fthud%2Fnightly%2F210%2Fapalis-imx8%2Ftezi%2Ftezi-run

Best regards,
André Curvello