IMX8 PCIe not discovered every time


I have a IMX8QM with latest BSP (3.0b3). During PCIe scan device is not found every times.

It have tested with Apalis IMX6Q and it works well.

Durring boot I have the following traces :

 [    5.855790] imx6q-pcie 5f000000.pcie: pcie phy pll is locked.
[    8.037671] imx6q-pcie 5f000000.pcie: phy link never came up
[    8.053855] imx6q-pcie 5f000000.pcie: PHY DEBUG_R0=0x0000bc43 DEBUG_R1=0x08000000

Apalis mounted on Ixora board (V1.1A).

I have tried at Gen1 and Gen2 but Gen1 works worst than Gen2. According to debug register device is not seen at all.

Is there any known issues about that ?

Best regards,

What exact hardware (module and carrier board) and software versions of things are you talking about?

No, the only known issue has to do with suspend/resume. However, there are a bunch of PCIe related i.MX 8QuadMax SoC errata which may be the root cause of what you are seeing.

I quickly gave this a try on my Ixora V1.1A with an Apalis iMX8QM V1.0B and a Broadcom mini-PCIe Wi-Fi card. It just passed more than 150 software reboots without any PCIe related issues at all.

Are you doing power-cycles or just software reboots?


Module is Apalis IMXQM 4GB WB V1.0B.
Carrier board is Ixora V1.1A.

I have tested with software reboots and cold reset but none is working better. Actually device is discovered 2 times out of ten.

Could you give me more information about 8QuadMax SoC erratas ?

I don’t think I ever tried any Apalis iMX8QM 4GB WB V1.0B. Need to first get my hands on any such.

Here you may find the SoC errata:

BTW: What exact PCIe device(s) did you try?

Thanks for the SoC erratas,

This may be cause by “ERR010930: PCIE: EOM single point sample error/valid result is not correct.”

Could I have PCIe IP documentation to implement the workaround ? I didn’t found PCIe registers documentation on NXP website.

Hm, looks like NXP has not yet publicly released the i.MX 8 family reference manual which would contain such information. Let me inquire with them about this.

Anyway, may you reveal what exact PCIe device(s) you did try?

I ask reference manual to NXP and they replied: “Please apply to local marketing office for obtaining preliminary Reference Manual.”

Unfortunately, besides NXP already having launched their i.MX 8 SoC back in November so far they have not publicly released any reference manual. But their launch basically terminated the early access program and therefore we no longer have any easy accessible space available.

Anyway, here you go with a link to that former “secret” preliminary one:

And good news I just got an answer from NXP:

“We’re working on closing out a few last minute items, the RM should be public before the end of Q1.”


PCIe divice is Artix-7 FPGA. It has been validated on Varicite SoM and on Apalis IMX6Q.

I ask reference manual to NXP and they replied: “Please apply to
local marketing office for obtaining preliminary Reference Manual.”

Thanks for your help.

I have test with a competitor board based on the same SoC (Same silicon mask) and it works well. BSP is based on Yocto 2.5 (Sumo).
So it may be a BSP isssue or a hardware issue on SoM or Ixora board.

Best regards,

Hi @thomas_P

Thanks for your valuable feedback.

I think you are seeing this issue, which we have seen on some samples of the SoM Apalis iMX8QM.

We will look into this and come back to you soon.

Best regards,

Hello, to exclude any other issues can you please explain how you connected the FPGA to the IXORA board?
Are you using an interposer?
Can you please discribe the setup or sent a picture of it.

Best regards,


HI @thomas_P

Could you also test the newest Bsp 3.0b4, we just released yesterday? I tested this on my board and I don’t see any PCIe issues which I have not seen before.

Thanks and best regards,


I have tested the Bsp 3.0b4 but it doesn’t help.

Best regards

Looks like NXP silently released some new RAM initialisation stuff which may fix the issue you are seeing. Unfortunately, we only have nightly BSP 4.0 builds with this so far. Could you maybe give that a try?


Toradex send me a new SoM with an earlier SoC and it works well.
The problem was in IMX8 chip.

Perfect that the issue is solved.
Enjoy using the new SoM.

Best regards,