iMX8 not recognizing SD card on boot

Iris carrier board v1.1A
TorizonCore 5.2+build.7 (2021-04-08)

The system does not recognize SD Card on startup. If I remove and reinsert the SD card after system has started, it works fine.
Is there a config procedure so it recognizes SD Card on startup?

Hi @luis_br ,

Could you give me more details about your situation?

  • When you say ‘recognize’, does it mean the SD card appearing in /dev/ or it being already mounted?
  • What file system is the SD card formatted with? FAT32, ext4?

I’ve made some tests with a 4 GB microSD card with the same SoM as yours, Iris V2.0A, and when running lsblk right after startup the SD appeared as mmcblk1, with its partition already mounted. This worked with the SD card formatted as FAT32 and ext4.

I believe the Iris version that I’ve used shouldn’t make any difference in the results.

EDIT: I forgot to ask, could you see if this happens in the newest quarterly TorizonCore release? (5.6.0 at the time of writing this)

Best regards,
Lucas Akira

Thank you for the quick answer.

After upgrading to the new TorizonCore and configuring the fstab properly, it worked fine.
I think it was actually a bad configuration of the fstab on our side. Former models we used to work with were always ‘mmcblk0p1’, this one is ‘mmcblk1p1’. I couldn’t check after the upgrade, but I guess we just had our standard config and that was the problem.

Glad you managed to get it working!

Best regards,
Lucas Akira