IMX7D V1.1D Random Boot Failure

Hello team,

We are facing random boot issue for WinCE7. When we reboot, sometimes the module does not boot. I have bought 5 IMX7, out of which 4 are creating similar issues.

Kindly let us know if there is any solution.

hi @kshah,

What is the image version flashed on your iMX7D?

Also, can you copy and paste the error it is showing here?

It does not show any error. alt text. It just get stuck at OEMLaunch: 0x80180000.

If I reboot again, it starts.

Hello @sahil.tx and @kshah,

We have the same problem with iMX7D 512 MB 1.1D on our own custom board and on the Iris :frowning: Every 3-6 starts, the system hangs just like @kshah has shown.

This is using Bootloader 1.3b4 with Image 1.3 B2 - WEC7.

Flashing it back to Image 1.2 WEC 7, I have tried starting it 20 times - without a single hang. So there is some flaw in the newer OS image.

For us, using image 1.2 is not an option, because we make use 24 bit colors, which isn’t working right in 1.2.

How can I help to narrow this issue down and it get it fixed?

Thanks for your support,

@kshah and @MessagePump Could you please enable debug output, then collect logs and post it here as a text file?

One more question - which version of Toradex Easy Installer have you used to flash an image?

Easy Installer 2.07 (20210415)

link text

Please see attached 2 text files. One is with the issue and one is without.

Could you please try to flash your “bad” module(s) using legacy method described here? Since you already have a eBoot you can do steps 3, 6, 7 ,11 and 12 only.

Pretty much the same thing here as reported by @kshah :
link text

I don’t remember which version of Easy Installer was used to flash the image.

Alex, I followed your instructions to flash using the bootmenu and the SD-Card, which worked fine. I then reapplied our filesystem, bootblock and registry images using the update tool. I got 10 successful starts, but on the 11th start it was hanging again.

I missed to make a series of tests with the clean OS without our changes. I will do that tomorrow and report back.

Was your filesystem image created under same BSP release (1.3b4) and by using same version of Update tool as it included in BSP 1.3b4?

Can you repro this issue if you have an original BSP without applying your filesystem and config block?

Hello @alex.tx ,

The module will still hang. This is what I tried:

Like mentioned before, via the bootloader, I had erased the filesystem and flashed nk7.bin (1.3b2). Thereafter I applied our bootblock, filesystem and registry images. The system hung on the 12 try.

Then, via the bootloader, I again erased the filesystem and reflashed nk7.bin. This time it hung on the eighth try.

Then, via the bootloader, I restored the bootblock with the restorefactoryinfo command. It hung on the second boot up.

My conclusion is, that there is an issue with 1.3b2 itself, because the hang up is independent of our filesystem and bootblock.

Is there anything else that would make sense to try?

I think my next step is to do a complete module recovery. I’m in my home office but the Iris is in the office at work. I’ll have more info next week.

Hello @alex.tx,

I did flash OS using SD card. I tested it for approx 25 reboots.
As of now it works fine without any issue.
I’ll do the same procedure with other modules and will let you know if any issues.

Perfect that your issue is solved. Thanks for the feedback.

Hello @alex.tx - it’s been some time, but I just wanted to let you know, that the issue was solved by using the latest WEC 7 image (1.3) and recreating the filesystem from there. Boot up worked fine since then.

Thanks for the update! Yes, we’ve fixed an issue with NAND bad block handling in 1.3 release.
A new release of WEC 7/8 is expected soon with more improvements related to flash subsystem.