Imx7d rpmsg wec7

I have hit a road block. The code successfully downloads and runs on the M4. I can get serial messages from it. However the dotnet RpMsgDemo does not sync with the M4 with any of their examples.
The wince library is 2.3. The compiler is VS2008. Computer is Win7 Pro. Vring0 is 0x8FFF000, Vring1 is 0x8FFF8000. We are using OCRAM. There is not any DDR.

Dear @gjump

Can you please post complete projects with source code along with the required information about how you built the binaries, so we are able to reproduce the problem here?

Regards, Andy

Download the M4 code from http://git.toradex.com/cgit/freertos-toradex.git/.
Download the WEC7 SDK from https://docs.toradex.com/102481
Download the WEC7 Examples from https://docs.toradex.com/102692-toradexcelibraries-preliminary-versions.zip.
The M4 code is compiled with MINGW using “clean.bat” followed by “build_all.bat”…The elf file is copied from the release directory to a SD Card.
The A7 code is compiled in VS2008. Change “Debug” to Release". Edit “Firmware”,(string)"…" to “Firmware”,(string)"\FlashDisk\rpmsg_str_echo_freertos.elf" or any of the other rpmsg samples. Compile said software and copy to same SD Card.
Plug SD Card into dev board. Copy ALL elf file to internal “Flash” drive. Plug Serial cable into dev board to test M4 comms. Run RpMsgDemo.exe. After a short period of time the M4 communicates. The A7 displays "Failed to create communications channel. Edit the RpMsgDemo for the next elf file and, … same error message on the A7.

Someone showed how to upload zip files. They can be found at https://share.toradex.com/zck7dlul3o6b2ti

Did you try to use pre-build binaries for M4 (rpmgsp_pingpong_example.bin) ?

Dear @gjump

You swapped the addresses RxRingAddr and TxRingAddr. If you set it back to the values as we defined them in the demo application, communication works without problems. Correct is:

RxRingAddr = 0x8FFF0000
TxRingAddr = 0x8FFF8000

If you want to change these addresses, you also need to modify the M4 code accordingly.

Regards, Andy

Andy
I have tried having the address as you suggested and swapped but neither work

using an IMX7D 512 WinCE7
all code set it back to the values as you at TX defined them
.BIN file rpmgsp_pingpong_example.bin won’t load the code is Looking for .ELF file
tried both toradexcelibraries 2.3-20181011 and 2.3b4567-20190404 with no difference

RPMSG Demo just hangs screen displays “Failed to create Communications channel” it is not locked up can X out.

Dear @gjump

I did some more tests and found that the C# version of the Rpmsgdemo did not always run reliably, especially not in release mode.

I simplified the demo application, now you should see no issue anymore. It will be part of the next library release. Until then, you can download the application below.

To use it, simply replace the demo code in

Toradex_CE_Libraries\libDemos\dotNet\RpMsgDemo\

with the downloaded file.

Regards, Andy

Andy
we have tried the edited code but we still fail to get the RPmsg working with TdxAllLibrariesDll.dll
Alex emailed us his .net2 and rpmsg.dll code and that works correctly
however your demo code .net3.5 and TdxAllLibrariesDll.dll does not run
we get a Failed to create communications channel error

Dear @gjump

I was just talking to Luka (Toradex). He told me he’s currently in direct contact with you to tackle the problem. To avoid working on parallel channels, I will leave further processing to Luka.
As far as I heard the major problem is already identified. I’m confident we are finding a solution which fits your requirements.

Regards, Andy

Thanks Andy
Luka is helping