IMX7D Colibri fdt_board

I created a custom dts that used to work with the linux kernel 4.9. But with the new u-boot version (01.01.2020), it will not start not start.

The custom dtb filename is “imx7d-colibri-emmc-mcm.dtb”. Of course I recompiled the device tree with the 4.14 kernel.

Colibri iMX7 # printenv fdt_board
Colibri iMX7 # run emmcboot
Booting from internal eMMC chip...
Colibri iMX7 # setenv fdt_board eval-v3
Colibri iMX7 # run emmcboot
Booting from internal eMMC chip...
46702 bytes read in 9 ms (4.9 MiB/s)
5340880 bytes read in 103 ms (49.5 MiB/s)
Kernel image @ 0x81000000 [ 0x000000 - 0x517ed0 ]
## Flattened Device Tree blob at 82000000
   Booting using the fdt blob at 0x82000000
   Using Device Tree in place at 82000000, end 8200e66d

Starting kernel ...

I noticed that u-boot change a bit. There is a boot.scr script. Is there any file check that prevent linux booting from custom dts ?

In the uEnv file the fdt board name is not the same

nfsboot=run setup; setenv bootargs ${defargs} ${nfsargs} ${setupargs} ${vidargs}; echo Booting from NFS...;dhcp ${kernel_addr_r} && tftp ${fdt_addr_r} ${soc}-colibri${variant}-${fdt_board}.dtb && run fdt_fixup && bootz ${kernel_addr_r} - ${fdt_addr_r}

emmcboot=run setup; run emmcfinduuid; run set_emmcargs; setenv bootargs ${defargs} ${emmcargs} ${setupargs} ${vidargs}; echo Booting from internal eMMC chip...; run m4boot && load mmc ${emmcdev}:${emmcbootpart} ${fdt_addr_r} ${soc}-colibri-emmc-${fdt_board}.dtb && load mmc ${emmcdev}:${emmcbootpart} ${kernel_addr_r} ${boot_file} && run fdt_fixup && bootz ${kernel_addr_r} - ${fdt_addr_r}

For nfsboot, the name is ${soc}-colibri${variant}-${fdt_board}.dtb and for emmcboot the name is ${soc}-colibri-emmc-${fdt_board}.dtb

I also changed the variant. That’s why it was working with NFS.


Thanks for your valuable Input. We will check and correct this.

Best regards,

HI @arnaud_infoteam

I talked to the developer team and actually we could not understand your issue. For emmcboot, the emmc is set as fixed, since all other options did not make any sense.

Further in your example, you set up fdt_board to eval-v3-mcm but it should only be mcm.

Best regards,

Sorry, for the useless question. But finally the dtb wasn’t correctly named in the bootfs… Thanks for the reply.

There is no issue. You are welcome.

Best regards,