Imx6ull WiFi Driver Crash

Dear All,

We are using the inbuilt wifi of the IMX6ULL module in our Product and we got a crash log as per the attached file(WiFiCrashLog-imx6.txt). After that, we must have to reboot our board.

I have also uploadedlink text the “wpa_supplicant-mlan0.conf” file for reference(Testing).

The scenario is easily reproducible using the below steps if we repeat 4-5 times. We observe that this frequently occurs if SSID is incorrect/unavailable.

  1. ifconfig mlan0 up
  2. iw dev mlan0 scan
  3. wpa_supplicant -B -D nl80211 -i mlan0 -c /etc/wpa_supplicant-mlan0.conf
  4. udhcpc -R -b -i mlan0
  5. iw dev mlan0 scan
  6. kill -9 [pid of wpa_supplicant]
  7. kill -9 [pid of udhcpc]

Humble Request to provide the Quick Support to solve this issue.

HI @nikunjp26

Could you provide the version of the hardware (including carrier board) and software of your module?

Have you done any changes to the software? If yes, please share the changes.

Best regards,
Jaski

Hi @jaski.tx

Hardware Version : colibri-imx6ull module with latest wifi chip and Colibri Evolution board V3.2B

Software version : Linux colibri-imx6ull 4.9.166-2.8.6+gd899927728be #1 SMP Mon Apr 1 14:10:54 UTC 2019 armv7l GNU/Linux

No changes from my side in software. Get the image from toradex and install on module.

Still, in-built wifi is crashed . check Logs link text

Regards, Nikunj

Hi @jaski.tx

any update on this issue ??

HI @nikunjp26

No, there are no updates. We will try to reproduce this Issue and will come back soon to you.

Best regards,
Jaski

Hi @jaski.tx

on your side please run above command which is mention in questions.

Regards.

Nikunj patel

Hi @nikunjp26

Could you install the Bsp 3.0b265 and use the kernel 5.3.7 and check if you still see the crash?

Thanks and best regards,
Jaski

Hi @jaski.tx

Download OS link : https://developer.toradex.com/software/linux/linux-software#Linux_Image_Downloads

Image Name : **Colibri iMX6ULL (3.0b2 | 2019-08-30 | 50.8 MB) (only for devices with 512MB NAND flash)**

colibri-imx6ull login: root
root@colibri-imx6ull:~# cat /etc/issue
TDX X11 2.6-snapshot \n \l

Colibri-iMX6ULL_Console-Image 3.0b2.65 20190830

We tried same steps with above image still not able to up the internal Wifi.
This is on our top priority because we must have to deliver the product with in 1 week.
Please check your side and revert with some helpful solution.

Regards.
Nikunj patel

HI @nikunjp26

The current solution for your issue is to take the image 3.0b265 and change this with the kernel 5.3.7 compiled with kernel modules and the device-tree from kernel 5.3.7 and flash this to the module. If again there is a firmware crash, then you need to restart connman and the wifi interface should work again.

If you are not able to compile the kernel 5.3.7, then you can use the attached files.

Best regards,
Jaski

Hi @jaski.tx ,

I’m not able to flash this kernel with 3.0b265 image using toradex installer.

It saying partition size is small for kernel .

regards,
Nikunj patel

hi @nikunjp26

Yes sorry, I forgot this. You can just change the size in image.json file for the image you want to flash.

Best regards,
Jaski

@nikunjp26,

ubi kernel partition size is 0x800000 by default, which is not enough for Jaski provided kernel. To fix u-boot update you may remove m4firmware partition and reuse its space

ubi part ubi
ubi remove kernel
ubi remove m4firmware
ubi create kernel 0x900000

then write new kernel, hmm, it depends how you load it to RAM from u-boot. For reference legacy 2.8b6 was doing it like this to update from USB stick:

fatload ${interface} 0:1 ${fdt_addr_r} ${board_name}/zImage && ubi write ${fdt_addr_r} kernel ${filesize}

You may use tftp or something, then ubi wite downloaded kernel. The same ubi write should be done for dts.

Hi Edward Thanks for your Input.

I did copy kernel and module for new kernel 5.3.7, Still got below Error:

root@colibri-imx6ull:~# uname -a

Linux colibri-imx6ull 5.3.7 #3 SMP Thu Nov 14 11:29:46 CET 2019 armv7l GNU/Linux

**udhcpc -R -b -i mlan0

udhcpc: started, v1.29.3

udhcpc: sending discover

udhcpc: sending discover

udhcpc: no lease, forking to background**

LOGS: link text

Hi @nikunjp26

I could not identify your issue:

Could you share the following in text files? Thanks.

  1. dmesg log
  2. output of iw dev mlan0 info
  3. output of wpa_supplicant -dd nl80211 -i mlan0 -c /etc/wpa_supplicant-mlan0.conf

Thanks and best regards,
Jaski

Hi @jaski.tx

I run the above command listed in my question.

I’m able to get the IP address but, after killing wpa_supplicant process
getting below error log. link text

Why the crash log is coming ??

Regards,

Nikunj patel

Hi @nikunjp26

You should not use kill -9. Usually connman and networkd is enabled in our regular Bsp. If you are using wpa_supplicant, then you should disable those.

Best regards,
Jaski

Hi @jaski.tx

As you said , I disable the connman and networkd service.

Still i’m getting crash logs. link text

Thanks for your Input. Why are you trying to kill the process? Could you try without -9 option? Thanks.

Hi @jaski.tx

Yes, i tried without -9 option and i’m not able to get any crash logs.

Thanks for the above solution.

But after running command (4-5 times) listed in question , i’m not able to connect via wifi or getting disconnected log .

7.812459] mwifiex_sdio mmc1:0001:1: Unknown GET_HW_SPEC TLV type: 0x217
[  687.992579] mwifiex_sdio mmc1:0001:1: info: MWIFIEX VERSION: mwifiex 1.0 (16.68.1.p179) 
[  688.000732] mwifiex_sdio mmc1:0001:1: driver_version = mwifiex 1.0 (16.68.1.p179) 
[  695.385804] ieee80211 phy5: sched_scan start : n_ssids=1 n_match_sets=1 
[  695.393285] ieee80211 phy5: n_channels=41 interval=10 ie_len=0
[  713.917681] ieee80211 phy5: sched scan stop!
[  713.955167] mwifiex_sdio mmc1:0001:1: info: trying to associate to 'SLS-WiFi' bssid ec:bd:1d:c3:90:b0
[  713.980757] mwifiex_sdio mmc1:0001:1: ASSOC_RESP: failed,    status code=17 err=0x21 a_id=0x0
[  713.989458] mwifiex_sdio mmc1:0001:1: assoc failure: reason Unknown connect failure
[  714.002127] mwifiex_sdio mmc1:0001:1: info: association to bssid ec:bd:1d:c3:90:b0 failed