[IMx6] No serial input on ttymxc0

Dear all,

I’m facing an issue on my custom board.
I have no more console input in Linux (work in uboot) on ttymxc0 but all messages are correctly printed:

Poky (Yocto Project Reference Distro) 2.0.3 apalis-imx6 /dev/ttymxc0

apalis-imx6 login:

I can’t type my login and so I can’t log in.

I can echo on ttymxc0 some dummy datas and that’s correctly printed.

My inittab:

# /etc/inittab: init(8) configuration.
# $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $

# The default runlevel.

# Boot-time system configuration/initialization script.
# This is run first except when booting in emergency (-b) mode.

# What to do in single-user mode.

# /etc/init.d executes the S and K scripts upon change
# of runlevel.
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6
# Normally not reached, but fallthrough in case of emergency.
mxc0:12345:respawn:/sbin/getty -L 115200 ttymxc0
# /sbin/getty invocations for the runlevels.
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
# Format:
#  <id>:<runlevels>:<action>:<process>

1:12345:respawn:/sbin/getty 38400 tty1

My setup variable:

setup=setenv setupargs fec_mac=00:14:2d:a1:8d:d1 consoleblank=0 no_console_suspend=1 console=ttymxc0,115200n8

When I kill /sbin/getty -L 115200 ttymxc0 process it is automatically respawned on console as expected but I can’t type any text.

Any advice ?

BR, Vincent

HI @VincentB

Could you provide the version of the Hardware and Software of your module?

Did you try if you get the serial input on one of the Toradex carrier boards?

Best regards,

Hi @jaski.tx ,

Hardware version: Apalis imx6 1.1B
Software : Poky based distribution, linux 3.14.28

I have not tried on Evaluation board (I will) but the console has worked at the begining of the project on our custom board.

BR, Vincent

HI @VincentB

Linux 3.14.28 is not supported anymore. We are currently working with our stable release Bsp 2.8 with kernel 4.9.

Best regards,