iMX6 Display Resolution

Hi,

I am trying to get the Colibri iMX6 to display in a resolution of 1024 x 576.
However when I change the registry and reboot, the display states “Input not supported” and I get a black screen.
I do get an image when I connect via USB CeRHost, but not through the VGA cable.
This is for every resolution over 800 X 576.

I tried to use the iMX6 DIsplay Tool, but it doesn’t enable the “Apply”-button.

Am I doing something wrong, since I was able to display at that resolution on the Colibri T20.

Did you just configure resolution or also changed pixel clock and the other timings?
Are you trying with the same settings you used on T20?
Can you measure the video signals (pixel clock, vertical and horizontal frequencies etc.)?
Usually the issue happens when there is something wrong in the timings/polarities of the signals.

I only changed the X and Y dimensions, since those were also the only thing I had to change on the T20.

It may be that some settings have different default values (polarities, pixel clock etc.).
Did you try using the display tool?
http://developer.toradex.com/knowledge-base/imx6-display-tool

Hi Valter,

I tried it, but the “Apply” button is always grayed out.
Therefore I am unable to apply the settings.

Apply is disabled (i.mx6 BSP does not support changing those settings on the fly), but save should work.
You can add the information to the registry and then save the registry itself, using the option inside start menu.
After a reboot you should see the new display settings applied.

I inserted the values directly in the registry, but still no image on vga output. Usb connection does show an image.

Can you provide information about your display and the registry settings you applied?
When you connect via remote display the resolution (1024 x 576) is correct?

Hi Valter,

Sorry for the late reponse, but I was on Holiday.
Here is an image of the settings we use, based on the display tool

Can you test if those match the settings on T20?
Pixel clock is 25.175MHz that is the standard VGA clock, considering that your resolution is higher I would had expected a higher clock rate.

I do not see the option to adjust this setting in the T20. I see all kinds of settings under HKLM\SOFTWARE\NVIDIA Corporation\NVDDI but no pclk.

Can you please dump those settings?

I exported the NVDDI settings.link text

link text

Do you have something also under HKLM\SOFTWARE\NVIDIA Corporation\NVDDI\LCD?

If you don’t, can you try to dump out splash screen settings?
You can enter the bootloader console (connecting a serial terminal on UARTA and pressing space and then ‘x’ as soon as the device boots) and type:
set ss
that would be useful if you can see a splash screen as soon as you power-up your device.

So I dumped out the T20 settings from the bootloader:[upload|b5sWj1lwmrLdm3P/Dsk9AfvXo7Y=]

And this is from the iMX6:[upload|Wj8WSoMltFVZ97PzD/82dYKZyMg=]

Do you see any splash screen on T20?
It’s configured for standard VGA resolution.
When the T20 runs windows CE is it using the full resolution (1024x576)?

Yes I do see a splash screen and when it is all booted up the T20 displays at the 1024x576 resolution.

Ok, probably the issue is that currently the T20 is using a standard vesa mode that matches your required resolution. This is a feature we currently don’t have on i.mx6.
On the other side 1024x576 is not a standard VESA timing, the driver on T20 approximate this to 1024x768.
You should see a message like:
Set LCD to 1024x768 (60Hz)
in the serial console output.
If you can provide us more information about your display (datasheet link would be perfect) we may provide the right configuration settings for it.