Image over ethernet for colibri t30

error net framework 2.0 when i try to take image over ethernet for colibri t30 using update tool how to fix it please.

Hi @Aladin !

Could you please share more information about your setup?

  • Which exact Colibri T30 are you using? Please share its full name and version
  • Which version of OS are you using? Please share its full name and version
  • Which version of Update Tool are you using?
  • How is your network setup to send the image to the Colibri T30 module?

Best regards,

Colibri T30 1GB IT V1.1.B BCT V1.0(800Mhz)
Windows CE 7.0 tegra v2.1 built 20 Feb 2018
Update tool 6.0.14(2.0…)
Connecting only with ethernet cable
I tried to restore an image taken by update tool of an instrument with nb.0 bmz files on another card by selecting the .cfg file but after that the latter can no longer start i dont have a carrier board only with ethernet cable using ftp

Please note that the Windows CE Update Tool cannot take an image over Ethernet unless the image is located on a mounted SMB shared drive.

Hi ,
I have already tried with pxa 320 and it works without any problem but with a single backup.bin file now I try with colibri T30 I obtain several files with extensions Nb.0, Bmz and .cfg and there I fail when restoration in another card

Could you please provide more details? Specifically, which steps have you taken to back up and then restore, and at which step did the failure occur, along with the exact error message?

1.To take the image I use Realvnc display and keyboard the lan connection is between my laptop and the instrument knowing that the latter does not have any USB port just the Can and the serial interface (rs232 and rs 485 ) which contains the toradex card I access the update tool and I take the image by saving the register before. To transfer the image to my PC I use the ftp protocol (for example wincsp software).
2.For the restoration I transmit the image by ftp to the RAM with the same software on the card, avoiding the /flashdisk ROM folder for the image in .bin (pxa 320) it works. For the image in (.nb0, bmz, .reg) colibri T30 after restoring all the bootloader register elements, Osimage, filesystem, splashscreen instrument can no longer start (boot) knowing that it takes the new network parameters and I even lose count username for The http and ftp interfaces. No message error.

Could you please provide a detailed description of the steps you took? It’s still challenging for me to understand what data was copied, how it was copied, and in which direction it was transferred… Additionally, could you please clarify the term 'Toradex card’? Is it referring to an SD card with a Toradex image? It would be helpful to know which files were transferred using the FTP protocol and from which system. Furthermore, I’m interested in understanding which registers you were saving.

I’m expecting something like:

  • Start “Update Tool” on Colibri T30 running Windows CE 7.0 v2.1
  • Back up system by clicking on “Backup All” button" to “\Flash Disk” folder
  • Transfer resulting ifles a,b,c,d, over network to a host PC using command ‘command’
  • Transfer files a,b.c.d from host PC to Colibri T30 using command ‘command’
  • Start Update tool on Colibri T30
  • Do steps x, y, z
  • Observe error message ‘error message’ on step z