I2c port 3 in Colibri T20 not working

Hi,
i am trying to interface the colibri T20 I2c Port 3 with an Atmel microcontroller. I have checked on the I2ClibDemo from your website and whenever i run the i2cscan() method i get only the RTC listed on the available buses with the address of 0x68. I am configuring my I2C Data and I2C Clock pins on the CAM_I2C_SDA(X1 pin number 127) and CAM_I2C_SCL(X1 pin number 133) respectively on the Colibri T20 module. I tried disabling the RTC using the article http://developer.toradex.com/knowledge-base/rtcsync . But i couldnt find any registry assigned under that key. I have tried even a sample code available in this link http://developer.toradex.com/knowledge-base/how-to-use-adc-pwm-i2c-library-in-vcsharp. Can you suggest me a suitable method to implement the same?

To disable the RTC on our carrier boards, you need to rename the following key:

"Launch48"="rtcsync.exe"

Just add any character in front of “rtcsync.exe” or order to prevent the RTC protocol from being loaded. On newer Evaluation Boards there is also a jumper to disconnect the external RTC (Jumper “INT RTC”).

One other thing could also be, that your I2C chip communicates with an other speed. See API function I2CSetSpeed (http://developer.toradex.com/knowledge-base/i2c-lib-api#a9c55f6320c3b2325a2a61108df99b79c ).

If you see the RTC chip in the code, it may could be a hardware issue. Is there anything that blocks your chip from running properly? Could you measure the signals?