i.MX7s LVDS settings to 10.1" HannStar HSD101PWW1 (1280x800)

Hi,

I’m trying to make the 10.1" HannStar HSD101PWW1 work on multi touch LVDS adapter (1280x800 resolution). The image do not fill the entire LCD area (see the image below). The display link: 10.1 HannStar HSD101PWW1 LCD Screen Display With Mounting Hole [HSD101PWW1-A] - US $40.00 : HAOYU Electronics : Make Engineers Job Easier

alt text

My .dtsi configuration:

			/*  */
			timing_wsvga: 1280x800 {
				clock-frequency = <48000000>;
				hactive = <1280>;
				vactive = <800>;
				hback-porch = <104>;
				hfront-porch = <43>;
				vback-porch = <24>;
				vfront-porch = <20>;
				hsync-len = <5>;
				vsync-len = <5>;

				de-active = <1>;
				hsync-active = <0>;
				vsync-active = <0>;
				pixelclk-active = <0>;
			};

I also configured the u-boot env:

setenv vidargs 'video=dcufb:pixclockpol:0,vsync:0,hsync:0,1280x800-16@60'

The xrandr output:

colibri-imx7 login: root
root@colibri-imx7:~# xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768      60.00* 

I’m not sure if these configurations are valid or not. Why xrandr do not show 1280x800? Which files should I configure?

I’ve read the articles on the following links but I could not manage to work.

http://developer.toradex.com/knowledge-base/display-output-resolution-and-timings-linux#iMX_6_based_modules

http://developer.toradex.com/knowledge-base/x-server-(linux)#Xrandr

Best regards

Run printenv and set the output here.

I had a similar problem and then I see that there was a video setting in bootcmd.


Cleiton Bueno

Blog | Linkedin | B2Open

Display resolution configuration from kernel command line is currently not available on Colibri iMX7. One need to choose the display configuration via device tree ‘native-mode’, this feature is added lately. With this feature one can have muliple display modes in device trees and can choose a mode by setting the ‘native-mode’ property to any available selected mode. By default we select 'wvga’ timings.

See also Device Tree Customization. Changing the default resolution to WVGA was actually not intentionally, I pushed a patch which fixes that.

Hi,

It worked! Thank you very much!

Regards