I get an error the first time I run vscode trying to debug with the "can't find command ssh"

Software summary

Bootloader: U-Boot
Kernel version: 5.15.77-6.4.0-devel+git.ddc6ca4d76ea #1-TorizonCore SMP PREEMPT Thu Jun 29 10:14:22 UTC 2023
Kernel command line: root=LABEL=otaroot rootfstype=ext4 quiet logo.nologo vt.global_cursor_default=0 plymouth.ignore-serial-consoles splash fbcon=map:3 ostree=/ostree/boot.0/torizon/22ee1c5396bd88d474d3651dcaa4f7aa0db281ec95cc575598571f70ceceb3dc/0
Distro name: NAME=“TorizonCore”
Distro version: VERSION_ID=6.4.0-devel-202309-build.13
Hostname: verdin-imx8mp-14762705

Hardware info

HW model: Toradex Verdin iMX8M Plus WB on Verdin Development Board
Toradex version: 0058 V1.1A
Serial number: 14762705
Processor arch: aarch64

Each day when I bring up vscode the first time after a reboot, I get the error in the subject line. If I close it and run the “source tcb-env-setup.sh” command after I close it and opening it again, then the error no longer appears. But if I run it before I bring up vscode, I still get the error and have to close and open it again. and run the command before opening it the second time. I launch vscode from the commandline in WSL Ubuntu 20.04.
Is there any way to stop this issue?


Hey @Evets,

I believe your set up is atypical to use vscode from WSL.

From the Setting up the Torizon IDE Extension 2 Environment
There is the caution note "For WSL 2, Visual Studio Code has to be installed on the Windows side."
So that would mean to launch vscode from windows side and connecting to the WSL via the windows side VScode.

To note:
tcb-env-setup.sh is commonly used when using Torizoncore-Builder CLI tool. Not with our VSCode Extension. I suspect you are able to have a workaround by creating the torizoncore-builder enviroment, and then launching vscode.


Hi @eric.tx
Yes, I have it installed on the windows side. This did not be the case, but it is now. I run it from the WSL side, but it doesn’t seem to matter what side I start it from.

I have found that I don’t always have to run the torizon building source file, I just have to run VSCode debug have it fail at that command, then exit VSCode and then bring it up again. Then it seems to work. This did not be the case, and this has changed. But whether I launch it from windows or WSL, I get the same result.



Can you post the error you are receiving?

My hunch is that docker is not set up to run a without root, and an error is being thrown because the extension needs to be able to create the environment to build the image.

This would be step two here: Set up the Torizon IDE Extension 2 Environment | Toradex Developer Center


debug ssh error
This is what I get. There is no other information in the terminal, as it looks normal.



I believe the IDE extensions setup needs to be addressed prior to the debugging issue. You really shouldn’t be running source tcb-env-setup.sh manually and reopening/closing VSCode.

Can you run through the setup again, making sure to address all of the requirements in the guide?