I changed the name of "explorer.exe" to get our program to launch without showing PCCard message on WinCE but now I cannot get to registry to reverse it

I have a customer system back for repair that Ethernet doesn’t work on it. I received the below error:

Upon trying to figure out how to solve it by editing registry settings I tried to solve the other issue of showing this “Unidentified PCCARD Adapter” message on WinCE page before launching our program.

I added an “u” at the begging of “explorer.exe” as I remembered I was told something like this will lead to the wince page not shown before launching our program.
It didn’t solve that problem and now when I try to come out of the program to go to registry editor and reverse things, the program hangs on the page and I cannot get to the windows start bit to open registry edit anymore. (the second image is actually taken of the problematic screen)
Can you please let me know how I can fix this?

Dear @shiva_eghbal

PCCard Error

The loading of the driver is possibly triggered by a floating GPIO pin. If you don’t use a PC Card (Compact Flash) you can disable the PCCard driver in order to get rid of the message:


There are two devices in your system which both try to use the same IP One of the two devices is the Colibri PXA270 showing this message. I cannot tell you what is the second device.
However, as the error appears at the customer’s location as well as on your desk, the chances are good that it is something which is shipped as part of your system. The second device’s MAC address reported in the error message (40:A8:F0:…) belongs to a Hewlett Packard device.

So you need to identify this HP device, and then reconfigure either the Colibri Ethernet settings or the HP Ethernet settings. The proper settings depend on your overall Ethernet architecture, therefore I cannot tell you what the correct settings would be.

Regards, Andy

I changed the IP address set on the program on the Colibri PXA270 module. I tried to ping it and although I get destination unreachable, it has 4 packets sent and received and 0% loss.
However still cannot communicate with the machine and the Ethernet symbol on WinCE is crossed. Is there any way that I can enable that?

Dear @shiva_eghbal

The Ethernet setup needs to be tailored to your network, especially if you go for fixed IPs. There’s two tests I recommend to start with:

  1. Verify that the hardware is still ok:
    Reset the Colibri registry, which turns it to DHCP mode. Connect it to a “regular” network and see whether you get a connection like this.
    Please note that the PXA270 requires a slightly different Ethernet circuit on the carrier board compared to all newer modules. On the Colibri Evaluation Board there are jumpers to switch this.
  2. If the hardware is still ok, you probably need someone with Ethernet knowledge, who can help you to configure the settings to your requirements.

Regards, Andy

Dear @shiva_eghbal,

Please follow this documentation for clearing the registry : https://developer.toradex.com/knowledge-base/clear-registry

I re-flashed the Colibri with backed up registry files and now I can get to the registry editor. However I still cannot connect to Ethernet.
Could you please let me know what I can do about that?

Hi @andy.tx
How can I reset the Colibri registry?

I have done it and still no connection.
It seems that there is something wrong with this Colibri module.
I tried another PXA270 with our program on it and it works.
I tried to re-flash the faulty Colibri with the flash image of the working module, however I still cannot get Ethernet connection with it.
Is there anything I can do?

Dear @shiva_eghbal,

Thank you for your reply.

Could you confirm your Ethernet hardware is working perfectly by following steps below

  1. Program the WinCE image on that module. It would be best if you program our standard release image from here : https://developer.toradex.com/software/windows-embedded-compact/pxa-wec-software#Binary_Image_BSP_and_Workspace_Downloads
  2. After reboot, verify Ethernet LED blinks on the Magnetics connector and also verify that the ethernet connection is working with another machine. Verify DHCP is assigned IP address to the PXA270 module
  3. If you found Ethernet LEDs not glowing and showing a different pattern of blinking then maybe Ethernet has gone bad.

If you found Ethernet hardware is working perfectly then we would need to look into the Ethernet configuration settings.
If you found Ethernet hardware not working then you would need to file RMA.

I did follow the steps.
Updated the program with the standard PXA270 WinCE image from the link.
The Ethernet LED lights blink.
I set the Ethernet setting on DHCP, however I don’t get any connection.
There is still a red cross on the Ethernet sign on WinCE page.
what can I do now?


Dear @shiva_eghbal,

Could you enable the debug log message and share the log with us. Please don’t forget you should set dbg.serial = 1 and baud rate is 9600

Any chance two MAC addresses are the same in your Network setup. Could you verify the module serial number and mac.cid is same?

If you wireshark tool, could you sniff the packets and search with the MAC ID filter and verify any packets are transferred from the Colibri PXA270 device?