How to upgrade VF50 from Image V1.3 to V1.5b4+? (registry not saving)

How should a Colibri VF50 module from WinCE6.0 image V1.3 to WinCE6.0 image V1.5b4+?

I used the boot menu to:

  1. Clear the registry
  2. Enter CommandPrompt mode
  3. run flashloader
  4. run flashimage nk6.bin (both boot and image are V1.5b6 preview)
  5. eraseflash filesystem
  6. I restart the module and use the images UpdateTool to change the splash screen
  7. Run a CAB file to change the registry and put a file on the flashdisk (RTCSync)

The registry will now not save. I get the message that the registry has been saved, but when the module is rebooted, the changes have not been saved. (Cab file changes from above have not been persisted.)

I had problems like this earlier that I though I had brought on myself, but this module was straight out of the box as delivered from Toradex and I am having the exact same problem. Unfortunately that is my last ‘fresh’ module, so I cannot do any more testing as to what is going on.

I have also tried erasing the first 128kb of flash and then writebcb and restorefactoryinfo. The registry will still not save.

What do I need to do to get these modules working with later images?

If I use the UpdateTool to upgrade from V1.3 to V1.5b4+, do I still need to go through the boot menu to do the “eraseflash filesystem” in CommandPrompt mode?

I found one more earlier imaged module.
The image update process itself is not the problem. Something in my production process is making the registry reset and not be able to be saved on these modules that have just been updated. What could cause that?
If I use the update tool to replace the ConfigBlock on a module that is not saving the registry with a ConfigBlock from another module, then the same module that was failing to save the registry goes through the same production process without problem (saving the registry as expected).

There are two settings dbg.regread and dbg.regwrite in the config block to disable reading and/or writing the registry. Did you possibly change one of these settings to 0?

>set dbg
dbg.serial:     0               (Debug Serial Output)
dbg.regread:    1               (Read from persistent Registry)
dbg.regwrite:   1               (Write to persistent Registry)
dbg.watson:     0               (Enable DrWatson)
dbg.msgbuf:     1               (Enable Debug MessageBuffer)
dbg.watsonsize: 1024            (Size in KB of DrWatson DumpBuffer)
dbg.msgbufsize: 128             (Size in KB of Debug MessageBuffer)