How to sync time from server computer in window embedded compact 2013

how to sync time from server computer in window embedded compact 2013.

Server Computer Running with Window server 2012 r 2 …

please share the commands. so i have set date,time and Time Zone form Server.

You can force a resync by running:
services refresh NTP0:
This will sync with defautl time servers, if you want to sync with a specific one you can configure it as described here:
https://msdn.microsoft.com/en-us/library/ms884926.aspx?f=255&MSPPError=-2147217396

Btw: correct is: services refresh NTP0:
(command and parameter are switched)

Second btw:
default time servers in WinCE 2013 V2.0 are:

  • swisstime.ethz.ch : closed
  • time-nw.nist.gov : closed
  • clock.cuhk.edu.hk : don’t know

Dear Sir,

i’m unable to set time from my server .

my Server ip is 192.168.1.54 please make a registey and send to me.

Thank you very much for the correction, I’ll edit main answer, not to hide my mistake, but to make it easier to find the correct information for people who will search the community.
Thank you also for the information about time servers. Unfortunately it seems that less and less NTP servers are available as a free service on the internet. We will try to fix that.

How did you configured it?
This should work:

[HKEY_LOCAL_MACHINE\Services\Timesvc]
"server"="192.168.1.54"

i have tried but not set time.

Can you check that the key has been correctly entered in the registry?
Can you try to ping the time server from command prompt (provided that it replies to ping requests?)
If you type:
services refresh NTP0:
the time is updated?
What is the time that is set when your device boot? Did you check if the timezone is also configured correctly?

that’s okay. it’s true. I recommend to use pool.ntp.org, so it will pick automatically a near NTP server.

services refresh NTP0 returns a message NTP0 not a valid service.
Using Colibri VF61 with WINCE 8.0

Dear @sriraminfotecchn

You are probably using an older OS image version.
Please make sure you are using our latest OS image V1.5 or later.
There are some time server problems solved.

Regards, Andy

I am using the V1.5.
I just started update tool (i wanted to update the image) . But when I clicked on Version Info

the bootloader (running) ID = Colibri vybrid Ver 1.5 and
Image (running) ID = Colibri Vybrid Ver 1.5 (CE 8.).

i tried again by make changes in registry with same error (services refresh ntp 0 gives not a valid service ntp0)
registry as follows
trustlocalclock 1
server → 192,168.1.106 1.pool.ntp.org (2,3 pools also)
UserProcGroup 2
Flags 16
Dll : sntpsvc.dll
Order 153
keep 1
prefix NTP
index 0
Autoupdate 1
ServerRole 0
threshold 8600000
recovery refresh 18000000

so what is going wrong ?

Dear @sriraminfotecchn
Please make sure you provide exact information, otherwise we will often come to wrong conclusions.
(In your initial questions you stated you are working with WEC 8 1.4 Beta 2)

In your server statement 192,168.1.106 there is a type (comma instead of dot). Try to fix this and see whether it solves the problem.

Regards, Andy

First, the 192,168.1.106 is a typo as I typed the same on this webpage here. It is fine at the board registry.
I did not post the WEC 8.1.4 Beta part of this post. Sorry if that is a mistake. I just added a comment . Again apologise if that is wrong.
The problem persists.

I tried using the TimeSync s/w from Zebra which when run connects to my PC (192.168.1.106) and gets time. Another button “Sync” sets the time to the time got. As I am not able to get the registry hack working, is there any way I can code a similar s/w like timeSync in C# to get time from NTP Server and set in the system.

Dear @sriraminfotecchn,

We have this C# sample code NTP sync.

Thanks for sharing this code. Sad to say I tried it without any results. the function SyncTime() returns true but the value is still 0 in the bytes result.

Dear @sriraminfotecchn,

I have tested this [project][1] to verify time server sync is working. Could you please try it on your side and let us know the feedback. If it is working, could you please port to C#?

Tested it on Windows CE 8.0 1.5 for Vybrid Built Dec 18 2017
[1]: https://share.toradex.com/lppkqjehx41s55g?direct

I have written a code in c# based a bit on your earlier code and others. This code is able to get the time from the NTP server and set it on the board. But the registry setting way is not working. I can share the ntp sync on c# if needed