How to show splash screen instead show booting output

Hello,
I am working with colibri imx7d platform. I am using 5.0.0 BSP version and I made my own image based on tdx-reference-multimedia-image.
When I turn on the system the display shows booting output but I need to show an splash screen instead. How can I do that?
I supposed that I have to make a recipe to do this.
Any idea that can help me.
Thanks.
Emmanuel

1 Like

Hi @emmaperea ,

Please take a look at this article.

On Yocto you will have to append some modifications into the kernel to add the splash screen, this question might help you on this task.

Best regards,
Daniel Morais

Hello Daniel,
Thanks for you reply.
I could disable console output with the setup u-boot variable.
I know that I have to set in kernel defconfig CONFIG_LOGO_CUSTOM_CLUT224=y.
I have 2 questions:
Where can I find the defconfig file that the image is using?
How can I set my custon defconfig? Because I try to patching /arch/arm/configs/colibri_imx7_defconfig but It dindn’t work because I dind in the platform:
root@colibri-imx7-emmc:/proc# zcat config.gz | grep LOGO
CONFIG_LOGO=y
CONFIG_LOGO_LINUX_MONO=y
CONFIG_LOGO_LINUX_VGA16=y
CONFIG_LOGO_LINUX_CLUT224=y
and It seems patching is no aplied.
And I try to aplly my defconfig file in linux-toradex_5.4-2.3.x.bbappend , where I did

FILESPATH_prepend := “${THISDIR}/linux-toradex-5.4-2.3.x:”

SRC_URI +=
file://defconfig
"
KBUILD_DEFCONFIG_colibri_imx7 ?= “defconfig”

And bitbake print these warnings:
WARNING: linux-toradex-5.4.115+gitAUTOINC+dbdbcabf0f-r0 do_kernel_metadata: defconfig detected in WORKDIR. colibri_imx7_defconfig skipped
WARNING: linux-toradex-5.4.115+gitAUTOINC+dbdbcabf0f-r0 do_kernel_metadata: [NOTE]: defconfig was supplied both via KBUILD_DEFCONFIG and SRC_URI. Dropping SRC_URI defconfig

HI @emmaperea ,

Answering your questions:

Where can I find the defconfig file that the image is using?
A: Please take a look at this article.

How can I set my custon defconfig? Because I try to patching /arch/arm/configs/colibri_imx7_defconfig but It didn’t work because I did in the platf yorm:
A: The article mentioned above has instructions on how to download our kernel repository, to achieve what you want you need to download the repository, configure the defconfig as displayed in the article, then you can do the changes you want and generate a new defconfig, if you have issues on this step, please take a look at this question.

About the issue where yocto is dropping your defconfig, the variable KBUILD_DEFCONFIG_colibri_imx7 should work, can you please try to change from ?= to = and check if the warning is solved? Also please check this question for more information.

Best regards,
Daniel Morais

Hi @daniel_m.tx,
Reading Yocto documentation and a lot of posts that had the same issue that me(custom defconfig is not applied) the only thing thats worked was changing configuration with fragments
defconfig fragments
I made this config fragments:

CONFIG_LOGO=y
CONFIG_FB_LOGO_CENTERED=y
# CONFIG_LOGO_LINUX_MONO is not set
# CONFIG_LOGO_LINUX_VGA16 is not set
# CONFIG_LOGO_LINUX_CLUT224 is not set
# CONFIG_LOGO_CUSTOM_CLUT224 is not set
CONFIG_LOGO_CUSTOM_CLUT224=y

I check the defconfig in build/.config and Its applied.
I made a recipie to copy my custom logo image in drivers/video/logo:

FILESPATH_prepend := "${THISDIR}/linux-toradex-5.4-2.3.x:"
SRC_URI += " \ 
             file://custom.cfg \
             file://myCustom_kernel_splash.ppm \
           "

do_configure_append() {
        cp "${WORKDIR}/myCustom_kernel_splash.ppm" "${WORKDIR}/git/drivers/video/logo/logo_custom_clut224.ppm"
}

COMPATIBLE_MACHINE = "(mx7)"

My custom logo is copied under drivers/video/logo as logo_custom_clut224.ppm.
But when I turn on the board I doesn’t show logo.
There is something else that I have to do? Do I have to tell to the system that the logo that has to show now is logo_custom_clut224.ppm in somwere else?
Regards,
Emmanuel

Hi @emmaperea ,

I’ve made some tests here following the steps provided at this question and it worked well, can you please try it and inform us of the result?

About your sources, it seems that everything is correct, did you pay attention to the resolution note on this topic?

Best regards,
Daniel Morais