How to setup the TTL serial interface connection between host and Ixora Carrier Board

For the Ixora Carrier Board Rev. v1.1 its datasheet states on page 28 that to use the serial TTL level interface one has to disassemble the jumper J3 (to disconnect signal UART3_RXD from the RS232 IC12 transceiver). The serial interface should be accessible over e.g. a USB-to-TTL-serial cable cable then when connecting it to UART3_RDX (connector X27, pin 27), UART_TXD (connector X27, pin 28) and GND (connector X27, pin 32). I use an Ixora Carrier Board v1.0A instead of v1.1. Has to be considered something different with this board version?

Procedure is the same for 1.0A boards.
You can find ixora 1.0 datasheet here

Thanks but its still not working. I am using this converter (TTL-232R-5V-WE) which uses 5V but the Ixora Board uses 3V3 for TTL (connector X27, pin 27 and pin 28). I guess this is the reason… (I did not think about because the Apalis Dev Board worked with the same converter cable.)

You are not supposed to connect the 5V logic signals to 3V3 tolerant signals, this might lead to permanent damage to signals on 3v3 side. Please use a two-way logic level shifter and interface your TTL-232R-5v-WE adapter via the shifter.

I connected the 3V3 variant of the TTL-to-USB cable with YELLOW/RXD to UART3_TXD, ORANGE/TXD to UART3_RXD and BLACK/GND to GND (color coding on datasheet page 17). But there is still no valid output observable… some symbols are observable (I assume the interface should still be working then).

What output you’re expecting? Make sure that serial is configured in the same way on both ends and hw handshaking is disabled.

I expect it to work like with the Apalis Dev Board (despite of the TTL level: Apalis 5V, Ixora 3V3) which had the same SOM assembled which I am using in the Ixora Carrier Board now…

There is no difference in voltage levels between ixora and apalis eval board.Voltage level is SoM specific and for TK1 anything above 3.3V may result in damage.
Do you have access to oscilloscope or a logic analyser so you can check ixora tx\rx when usb serial is connected and disconnected?

no, unfortunately not.

can you share a script or an app that you’re using to send data over UART3 so we can try reproducing this issue?

That honestly should work just fine.

  1. First disconnect JP3.
  2. Then connect your USB-to-serial adapter’s RX to UART3_TXD X27 pin 28 and TX to UART3_RXD X27 pin 27.
  3. Now test it according to the following article on our developer website e.g. as follows.

Please see the

for the concrete setup on our side.

Open a screen session off your USB-to-serial adapter:

[user@host ~]$ screen /dev/ttyUSB6

Send some characters from the target:

root@apalis-tk1:~# echo test > /dev/ttyTHS2

Observer the output:


Now prepare for reception on the target:

root@apalis-tk1:~# cat /dev/ttyTHS2

Send something from your workstation:


And observer it on the target:


I have the exact same cabling despite of GND of the cable which I have connected to connector X27 pin 32 which should be ok as well. I try to debug it later…