How to Install Ubuntu on Apalis TK1


The answer to my question may end up being very obvious, but I have spent the whole day trying to install Ubuntu on the Apalis TK1 to no avail. I probably missed a step somewhere, so I will recount my steps here.

  1. Installed Ubuntu 14.04 on Parallels VM
  2. Downloaded NVIDIA TK1 JetPack 2.2
  3. Downloaded Apalis TK1 Linux Image 2.6
  4. Followed the instructions to replace roots in the Linux image
  5. Performed the sed and sh steps to prepare installation kernel
  6. Ran sudo -o DRIVE to a FAT32 micro-SD card
  7. I rebooted my Ixora board in recovery mode by holding down the button next to power adapter, while holding down the power button.
  8. When booting I hit a key to stop it from auto loading, but we boot into the embedded OS anyhow. Since we’re not booted into the Boot Load, none of the U-Boot commands work.
  9. I connected my Ixora board with TK1 into my MacBook Pro and booted in recovery mode once again. The USB showed up on my VM and shows up in Ubuntu when I do dmesg. The output is as follows:
    [  853.220750] rndis_host 1-3:1.0 usb0: unregister 'rndis_host' usb-0000:00:1d.7-3, RNDIS device
    [ 4140.285060] usb 1-3: new high-speed USB device number 6 using ehci-pci
    [ 4140.431893] usb 1-3: New USB device found, idVendor=18d1, idProduct=0001
    [ 4140.431896] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 4140.431897] usb 1-3: Product: Android
    [ 4140.431898] usb 1-3: Manufacturer: Android    gr8rFiV8US03C03C00
    [ 4140.431899] usb 1-3: SerialNumber: 0123456789ABCDEF
    [ 4140.463268] rndis_host 1-3:1.0 usb0: register 'rndis_host' at usb-0000:00:1d.7-3, RNDIS device, 52:e2:e4:a1:df:78
  1. Finally, the device does not show up in /dev/ as ttyUSB0 as was suggested. I tried setting up mincom, but since I do not which device to listen to, it does not work. I tried quite a few of them to no avail as well.

What obvious step am I missing?

Thank you for your help in advance.

Concerning step 7: Please note A) To have referred to button initiate the recovery mode on Ixora an assembly option would have to be performed as explained in section 3.2.2 Power Control on page 13 of the Ixora data sheet. B) However the recovery mode is usually only required should your board no longer be booting at least into U-Boot.

Concerning step 8: While I guess you probably performed this on a locally connected keyboard the idea would be to perform those U-Boot commands on a RS232 aka serial debug console. Have a look at the following article on our developer website concerning the development setup. Alternatively one may be able to initiate the same via fw-utilities directly from within a Linux shell by carefully modifying U-Boot’s bootcmd followed by a reboot but that is not only more complicated but also leaves you without any immediate feedback.

Concerning step 9: I doubt you actually entered the recovery mode but rather regularly booted your Apalis TK1 with its USB device connection providing regular USB RNDIS aka Ethernet-over-USB functionality. You should actually also get an IP address assigned on your Mac’s usb0 Ethernet interface by DHCP which would allow IP connection to your Apalis TK1 actually defaulting to

Concerning step 10: I guess you are talking about USB-to-serial functionality which on Ixora would require a dedicated IDC adapter cable on X22 followed by a null modem cable and a discrete USB-to-serial adapter connected to your Mac. Have a look at the following article concerning said details. The easiest would be to use our carrier board accessory kit as indicated here.