How to enable Wi-Fi on Apalis iMX8QM v1.1D

Dear all,

i’m working with the following configuration:
Apalis iMX8QM 4GB WB IT V1.1D
Ixora Carrier Board V 1.2A
DISTRO_CODENAME = “kirkstone”

root@apalis-imx8-14759920:/sys/bus/pci/devices# uname -a
Linux apalis-imx8-14759920 5.15.77-6.3.0-devel+git.3592e06b1bda #1 SMP PREEMPT Wed May 24 16:25:17 UTC 2023 aarch64 aarch64 aarch64 GNU/Linux
root@apalis-imx8-14759920:/sys/bus/pci/devices# cat /etc/issue
TDX Wayland with XWayland 6.3.0-devel-20230718073722+build.0 (kirkstone) \n \l

i would like to improve it enabling Wifi Connection.
I can’t see wlan0 interface we I run ifconfig, and if I try to run connmanctl enable wifi I get the following error:

root@apalis-imx8-14759920:~# connmanctl enable wifi
wifi is not available

After that, trying to find a solution I alsa watched to the dmesg with the following result:

root@apalis-imx8-14759920:~# dmesg | grep wifi
root@apalis-imx8-14759920:/sys/bus/pci/devices# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,DYNAMIC,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:14:2d:e1:37:f0 brd ff:ff:ff:ff:ff:ff
3: can0: <NOARP,ECHO> mtu 16 qdisc noop state DOWN group default qlen 10
4: can1: <NOARP,ECHO> mtu 16 qdisc noop state DOWN group default qlen 10
5: usb0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether ee:fd:8e:5c:78:f1 brd ff:ff:ff:ff:ff:ff
    inet brd scope global usb0
       valid_lft forever preferred_lft forever
    inet6 fe80::ecfd:8eff:fe5c:78f1/64 scope link
       valid_lft forever preferred_lft forever
root@apalis-imx8-14759920:~# connmanctl technologies
  Name = Wired
  Type = ethernet
  Powered = True
  Connected = False
  Tethering = False
  TetheringFreq = 0

Can someone help me with this issue, pls ?

Hi @sjjin , are you sure you are using a WB enabled version of the SOM? You mentioned WB IT V1.1D but we never released that version to the public. Is either WB IT V1.1C/E or IT V1.1D.

Please check if the SoM has the WB module:


Kind regards,

Hi @alvaro.tx,
My mistake was using a non-WB supported version of SOM.

I’ll connect the WB support SOM and try again.
Thank you for answer.

Best regards,