How to enable RTC on Colibri iMX7 1GB


On your default image internal-rtc is working ok.

I have created customised yocto image and able to boot from sdcard.
I’am able to set the current date and time in hwclock ,but on reboot it is not able to show current date which i stored in hwclock. It is because i’m booting from sdcard ?? or any other issue ?

Log file : link text


hi @nikunjp26

Could you provide the exact version ( uname -a ) of the Software of your module? What did you change exactly for your customised image?

Please use the following commands to set the RTC correctly?

Thanks and best regards,

Hi @jaski.tx ,

root@colibri-imx7-emmc:~# uname -a

Linux colibri-imx7-emmc 4.9.84-+gb2a7f2f #10 SMP Mon Dec 31 14:26:57 IST 2018 armv7l GNU/Linux

i’m able to set correct date using the above command (link given by you) , but on reboot i’m not getting correct date which i saved in hwclock.

FYI : my linux image is in sd-card only , not on module. Is that issue ??


Are you doing a soft or hard reboot?

i’m powering off the board

could you try to do a soft reboot ( reboot ) and check the behaviour?


on soft reboot it is giving correct stored date from hwclock.



Did you connect a battery on your carrier board? Can you enter the command ‘sync’ before you poweroff/on the board?

Additionally could you provide the output of hwclock and timedatectl when you poweroff/on the board after setting the hardware clock? Thanks.

Hi @jaski.tx,

the battery is connected on board.

Check attached file for hwclock and timedatectl command output. link text


root@colibri-imx7-emmc:~# hwclock -w
hwclock: can’t open ‘/dev/misc/rtc’: No such file or directory

There is something wrong with your configuration. This command should work out of box.


This is a very old Bsp, could you update to at least 2.8b4?

Thanks and best regards, Jaski