How to deactivate Auto-Crossover for Apalis iMX6 (WEC2013)


we need to deactivate auto negotiation and auto crossover for Apalis iMX6 for ENET1.
I found how to deactivate auto negotation:

“SpeedMode”=dword:0x00000064 ;Default no key = atuonegotiation, 1000=1GB, 100=100MBit. 10=10MBit ( 1GB is only valid for Apalis iMX6 )
“DuplexMode”=dword:0x00000001 ;Default no key = auto-negotiated. 0 = HalfDuplex, 1 = FullDuplex

But I could not find a way to deactivate auto crossover.

Is it possible and how to deactivate it?

Best regards

Unfortunately deactivating of auto crossover is not supported.


I checked the Datasheet from the Michrochip KSZ9031.
Under chapter 3.3 they mention that it is possbile to disable Auto-MDI/MDIX.

Auto MDI/MDI-X is enabled by default. It is disabled by writing a one to Register 1Ch, Bit [6]. MDI and MDI-X mode is set by Register 1Ch, Bit [7] if Auto MDI/MDI-X is disabled.

So my question is, would it be possbile to adapt the driver to get this working?

Best regards,

Yes it’s possible. But current version of driver does not support an auto crossover deactivation and we have no plans to implement it. Why do you need to disable it? How is it important for your project?

Hello Alex,

we have a onboard ethernet communication which causes a capacitive coupling.
We disabled on an older Hardware the Auto MDI-X feature which solved this problem.
So we would like to disable it. You can also make us a offer for the adaption.

Best regards, Dirk