How to configure the initial telnet password on WEC2013 - T30

I am unable to access the remoteadmin page to configure the initial password that the telnet server requires. I have tried 2 different browsers but each gives the same response that the URL doesn’t exist… I read that the web interface isn’t supported under WEC2013. How then do I configure the admin password for use by telnet?

Please have a look at the following answer: https://www.toradex.com/community/questions/2021/remote-admin-web-interface-on-wec2013.html

Thank you for the reply but I had previously found that post and the links were of no help… The first one relates to settings other than the password which I do not need (not to mention its for CE6). The second, is a dead link that doesn’t go anywhere.

I fixed the second link and directly pointed to the right article for WEC2013. The example talks about telnet, but the users are shared between features such as ftp, telnet, etc.

Many thanks :slight_smile:
Setting the password using the webserver worked nicely.

I’m also using T30 (Apalis) with WEC2013 in it and having the same problem. So there is no other way to create new user and password without bulding new system image with Platform Builder? I need to protect Telnet and FTP connections with customized passwords so it would be nice if it was possible without rebuilding whole system.

@jtyma: You could use the function NTLMSetUserInfo in a custom application. In order to use this, you need to get ntlmssp.h as well as Ntlmssp.lib from your Platformbuilder folders, as this is not part of the SDK.

@jtyma: I have update the ticket and uploaded a sample application, that you can use in your project. This allows you to update / modify user credentials. Please check [the updated answer][1].

[1]: https://www.toradex.com/community/questions/2021/remote-admin-web-interface-on-wec2013.html .