How to change WinCE to LINUX using EasyInstaller?


I have installed WEC7 on Colibri iMX6 Solo 256MB It. I would like to change OS image to LINUX using EasyInstaller.

I downloaded EasyInstaller but, I don’t know how to run it.

What should I do to run EasyInstaller like first power on Colibri modules?


Please follow this article to use toradex easy installer. You need to run recovery-windows.bat on Windows PC or on linux PC and module should be recovery mode. Those files will be

Let us know if you face any issue on this.

I already read that article so many times but, it doesn’t work.

I connected Colibri iMX6 to my PC with RS232 and I can see boot log from the terminal software.
I turned on the board and hit the [space]key.
I tried excute “recovery -windows.bat” but, result was “no matching USB device found”.

What did I wrong?

@smartek ,

Which carrier board you are using?
if it is Colibri Evaluation Board, did you connect USB OTG (X29, adjacent to RESET button) port to the PC?

I’m using Colibri Evaluation board and I connected USB OTG X29 but, I could find any new device in Device Manager in my PC.

Also I’ve tried with recovery jumper on CPU module but, result was same.

Did you try follow this steps:

- 1. Open a terminal on your host computer (115200 baud, 8 data bits, no parity, one stop, no hardware/software flow control).
- 2. Power cycle the board and immediately press [space] on the terminal
- 3. you should see a menu, in this case type 'X' to enter the bootloader console, then on the Eboot command line:

bootfrom usb

If a boot delay interval set to 0 it may be hard to get to menu on step 2. SO you should repeat step 2 until you get to boot menu.

I did same as you described. (see attached image)

And then, I tried excute “recovery -windows.bat” but, result was “no matching USB device found”.

The problem is Host PC can’t find matched USB port(Colibri Evaluation Board).

I think when I pluged USB OTG(X29) cable to my PC then it should appear Device Manager.

It really seems that your Host computer is not enumerating the USB device.

Which Windows version are you using?

The device should appear under “Human Interface Device”. In properties, Details then “Bus reported device description” it should appear as “SE Blank RIGEL” (see also this screenshot of the device manager).

If it does not, make sure to follow the steps in the Colibri iMX6 section of the Toradex Easy Installer article exactly. Make sure to not use X30 while using X29 and remove any SD card.

When I plug USB cable to my PC then I could never find new USB Input Device as “SE Blank RIGEL”.

I think this is my problem. I searched to install this driver manually but, I could never find anywhere in the internet.

How can I install this driver manually or fix this problem on my PC?


Just to clarify - new USB input device will appear at Device Manager only when Colibri Module booted in recovery mode.

There will be no need to install a driver. Windows can handle the device just fine. It should just appear. If it does not, the module is not in recovery mode or there is some connectivity issue.

Replace USB cables, and please make 100% sure to follow the documented steps, make sure to not use X30 while using X29 and remove any SD card.