How do I specify the exact Qt version with Torizon


I want to use Qt6.5 with Torizon, but don’t know how to specify that.
Should I be editing the Dockerfile?


Greetings @msmith,

First of all you’ll run into 2 issues here.

One, the Qt6 packages do not have hardware acceleration currently. While you can create applications with Qt6 the performance will probably be less than great. Though this is something our team is currently working on so hopefully this gets improved soon.

The next issue is the version of Qt6. You are more or less at the mercy of whatever version of Qt is being distributed by Debian currently. Our latest Debian containers are based on Debian Bookworm. If you see here the current version of Qt6 on the Debian feeds is version 6.4.2: qt6-base - Debian Package Tracker

Though I do see the Debian maintainers have a high priority action to package Qt 6.5.1, though I’m not sure when that will happen.

All that said, I have some questions for you.

  • How urgent is this for you?
  • For what reason do you specifically need Qt6.5? Will the currently available 6.4.2 not suffice?

Best Regards,

Thanks Jeremias

Our project is currently Qt5 as we need QtLocation, hence the need for Qt6.5 rather than 6.4. Hardware acceleration is important too, so I guess we will be sticking with Qt5 for the time being.
Do you have a timeline for getting that included?

We have a working solution now, so the upgrade is not urgent, however we do need to take advantage of the new VS Code Extension and the CI/CD capabilities. Do you see any issues changing the Qt template to Qt5?


Do you have a timeline for getting that included?

I don’t have a precise timeline other than “soon”. All I can say is that the team is actively working on this now and are making good progress, assuming no unforeseen issues occur.

Do you see any issues changing the Qt template to Qt5?

Are you thinking of creating a new Qt6 project in our VSCode extension V2, but modifying it to instead be Qt5? If that’s the case I can’t think of any immediate issues. You would just need to change packages being installed in the project from Qt6 to the Qt5 equivalents.

That said, I don’t believe anyone has tried this so there may still be unknown issues with this.

Best Regards,