How do I increase SPI buffer on IMX8


We are changing our system from Apalis TK1 to Apalis IMX8 and for our software to work we need a buffer size bigger than 4096 on SPI. We used on Apalis Tk1:

cd /sys/module/spidev/parameters
chmod 666 bufsiz
echo 65534 > bufsiz

But when we tried to use the same script on IMX8 we got the error:

echo: write error: Input/output error

We also tried creating the file

root@apalis-imx8-06944749:/sys/module# vi /etc/modprobe.d/spidev.conf

but when rebooted did not work, checking the SPI buffer size after we only got the same value:

root@apalis-imx8-06944749:~# cat /sys/module/spidev/parameters/bufsiz

How can we change the SPI buffer on Apalis IMX8?

Hi @icarofcb ,

The best alternative here should be changing the spidev kernel module parameter. Can you please try the same approach explained in this question and let us know if it works?

Best regards,
Daniel Morais

Hello Daniel,

Thank you for you reply.

We saw the topic you mentioned and we already tried that approach and it did not work.

Best regards,

Hi @icarofcb

Can you explain a lit bit more how did you run the tests?

Larissa Souza