How can I see Toradex GUI after recovery mode?

  • I couldn’t see the GUI after the following. Select "Toradex Embedded Linux Demo with LXDE(Statble) ==> Download the data ==> Select “Reboot”
    I don’t understand I only selected “Reboot” and then I couldn’t see anything.

alt text
alt text

Anyway, I tried to use recovery mode, and then I can see some screen like the following but I can see the GUI.
alt text

The progress is stopped. What is the next step? I want to see your GUI. Now, network is connected but I couldn’t see the next step. If I enter any key, it request me the login ID.
alt text

Please let me know how to recover the final image. I searched your community but I couldn’t find the way.

  • I have another question. Even though I connected a UART cable like the following, but I can’t see anything. Is serial part in PCB board broken?
    alt text

alt text

Hi @HansKim72 and Welcome to the Toradex Community!!

The progress is stopped. What is the next step? I want to see your GUI. Now, network is connected but I couldn’t see the next step. If I enter any key, it request me the login ID.

There is no GUI, since you installed the Console Image. For having a GUI, you need to install the LXDE Image.

Please let me know how to recover the final image. I searched your community but I couldn’t find the way.

Sure, you just need to follow the instructions described here.

I have another question. Even though I connected a UART cable like the following, but I can’t see anything. Is serial part in PCB board broken?

Which UART Converter are you using? What is your Host OS?

Best regards,
Jaski

I used a UART converter that supports up to four serials. Of course, I’ve also tried the uart converter in your box.

Hi Jaski,
I followed your instruction. My colleague select “recovery-windows.bat”, and then we could see the upper screen. What is the next? Am I still wrong?

I want to run Toradex easy installer in console image. Is there an easy way? Your web site information is difficult for me because there are so many contents.

This should work out of box. Can you check again the cabling.
It will be helpful, if you could share some pictures of your connection?
Thanks

Hi Jaski, I followed your instruction. My colleague select “recovery-windows.bat”, and then we could see the upper screen. What is the next? Am I still wrong?

Which Screen did you see?
If you see the Toradex Easy Installer Screen with Choices of Images to install, then you need to install Toradex Embedded Linux Demo with LXDE (Stable).

Note, the module should be connected to Internet or you need copy the image to a USB key or SD Card.

alt text

alt text

Do you need more pictures?

Hi, I think there is some confusion here what the Toradex Easy Installer is.
The Toradex Easy Installer just makes it easy for you the load different Images with the comfort of a GUI.
After you select you select an Image it installs it and wipes out the Toradex easy installer.
And than it boots into the Image that you installed.
In your case you selected a console Only image. So you should see it over UART booting.
If you do not check your UART connection.

I fixed my board. I executed “recovery-windows.bat” on my PC after short the jumpers on the board. Then the board returned to its original condition.
Thank you.

alt text

Thank you for the pictures.
I think the Problem with the UART is that you are using just a gender changer but you should use the grey NULL modem cable provided in the cable box.
Other wise the TX RX lines are not swaped.

Best Regards

I’m still not using the UART, even though I’ve recover the board.

Ok, but if you want to use it, you know what to change in your cabling.

Perfect that it works. Thanks for your feedback.

I want to run Toradex easy installer in console image.

This is not possible. So you have three possibilities:

  1. Either you can boot up Toradex Easy Installer
  2. Or you can boot up the Console Image after installing (which does not have any desktop)
  3. or you can boot up the Lxde Image after installing (which has a desktop)

Is there an easy way? Your web site information is difficult for me because there are so many contents.

What is difficult? Installing images using Toradex Easy Installer is the easiest way you can have.

I think there is a hardware problem because there is no UART output. What do you think about it? I’m using many USB to serial converts and they work fine because I’m developing STM32F7 board. There is no any problem of UART.
I also checked wifi and bluetooth and there is a problem. I’d appreciate it if you could check the following community. I’ve been using this board for only three days.
https://www.toradex.com/community/questions/42326/wifi-bluetooth-error.html

Did you use the null modem as proposed by @matthias.tx?