How can I make rpm instead of ipk packages?

I have selected PACKAGE_CLASSES ?= “package_rpm” in my local.conf file and commented out the line #PACKAGE_CLASSES ?= “package_ipk”, removed the deploy/ipk files, removed the tmp_glibc files, and removed the sstate_cache files and executed the following bitbake command:
bitbake -k angstrom-qt5-x11-image but it continues to build ipk packages. How can I build rpm packages?

Hi

Note that the -e switch of bitbake helps to debug variable settings.
e.g. search for PACKAGE_CLASSES in the build.log after running bitbake:

bitbake -e angstrom-lxde-image > build.log

Looks like meta-angstrom takes precedence in ‘layers/meta-angstrom/conf/distro/include/angstrom-core-tweaks.inc’-

Its a bit tricky to override that. Maybe replacing ‘PACKAGE_CLASSES ?=""’ with the following in conf/local.conf helps:

PACKAGE_CLASSES_append = " package_ipk"
PACKAGE_CLASSES_remove = "package_rpm"

Max

Hello Max. I added the above lines except swapped and my build is now creating rpm packages. However I get ERRORs every time bitbake executes a do_package_write_ipk. Why is it still trying to execute that task? Do I need to blow away my deploy/ipk drectory structure first and then relaunch the build?

Hi

I did not actually try to build, sorry about the swapped ipk vs. rpm settings.

I don’t know why it still builds ipk. What does one of these error message really look like?

Max

how do you add the ipk package manager software to the build.

That should be included by default and is called opkg.

BTW: Rather than hijacking old questions it would be better to ask a new one exactly starting what versions of things you are talking about.