How can I install the Usb to serial driver on apalis TK1?

I have followed the apalis_tegra_k1_user_guide_linux.pdf to install the Ubuntu on Apalis tk1 successfully.
I want to install the driver of the usb to serial (such as FTDI,cp2102,CH340,pl2303),but until now I haven’t found the way to do this.
Before this board , I have used the JETSON TK1 and I used to add these dirver via ‘make menuconfig’
So is there any way to install the driver on Apalis tk1?

Hello @Sunqinglin

Welcome to Toradex Community!!!

You can follow the instructions on our developer article either to do the cross or native compilation of the serial driver.

Best regards, Jaski

Thanks for your reply, I hanve followed the article you metioned,but I still have some trouble in installing this driver.
I do all the things as the article said:

Now configure and compile the kernel as follows:
ubuntu@tegra-ubuntu:~$ cd linux-toradex/
ubuntu@tegra-ubuntu:~linux-toradex$ make apalis-tk1_defconfig

after this ,I run the ‘make menuconfig’ command to add USB to Serial drivers in image file.
After this,I continue to fllow the article,build the uImage and copy the uImage ,dtb file to /media/ubuntu/boot/
when I reboot the system,It can not recognize the usb to serial module either.
but I found there are one more directory in the path of /lib/modules/,and there isn’t the ‘build’ dir in the original directory,I can;t build the .ko file to insmod.
Have you seen this problem before?
Hope for your response,Thanks(Can I describe my problem in Chinese? You can see that I am not good at English… )

So you build the kernel. How did you compile the driver as kernel module or built in?? If you chose kernel module, then make and deployment of the kernel should be done.

I think you can talk well English. If you still have issues, you can write an e-mail to, then someone of our Chinese office can answer this.

I try to compile the dirver both as kernel module and built in.but it didn’t work.
My understanding of ‘deployment of the kernel’ is copying the uImage and dtb file to target boart path of /media/ubuntu/boot,am I right?
Is there any other process I should do?

I try to compile the driver both as a kernel module and built in.

I hope you mean you tried once as a kernel module and once as built-in as those two options are mutually exclusive as either one builds a driver as a kernel module or as built-in otherwise they will conflict!

but it didn’t work.

How/what/where/why exactly “didn’t work”?

My understanding of ‘deployment of the kernel’ is copying the uImage and dtb file to target board path of /media/ubuntu/boot, am I right? Is there any other process I should do?

Starting with BSP 2.8b2 it is actually the zImage that should be used instead of the uImage. Maybe that was your issue? I updated the article in that respect.