Help with linux system freeze

I’m using new 2.5Beta2 image for your Colibri iMX6DL 512MB IT on Carrier board Iris V1.1A.
If I turn on the board, I can do whatever I want to, until I try to start Firefox. If I start Firefox web browser, system will freeze and I can do nothing (can’t move with mouse or do anything on keyboard - even ctrl+alt+F1 - F7 to change terminal is not working). System is “freezed” and nothing happens (even no changes on screen, no error message).
But if I try to start Firefox over terminal (not serial) here on Toradex board, only one message appears on the terminal and then system will “freeze” - that message is:

“GLib-CRITICAL **: g_slice_set_config: assertion ‘sys_page_size == 0’ failed”

and now only system restart will help.
This is happening everytime I want to start firefox - I can never manage to start it now.
But it used to work for the first time after I have uploaded your new image (2.5Beta2).

That is not what we experience. What exactly are you doing with firefox, did you install any extension, do you need to browse to a certain address, have a homepage configured?

Does it help to delete the firefox cache and settings? e.g.
rm -rf /home/root/.mozilla

Does it help to reinstall the image, i.e. attach the prepared SD card to the carrier board and do the ‘run setupdate’ ‘run update’ again?

We have no homepage configured - I think that I
only checked to open last session pages. We didn’t install any
extensions. Removing (“rm -rf /home/root/.mozilla”) didn’t help.
Yes, reinstall image will help, I tried it for two times and always it
helped, but after system restart it appears again (yes everytime I have
changed settings of firefox).

And may we ask what exact firefox settings you did change? Have you by any chance tried whether not touching any settings makes it freeze as well?

On my own compiled image (OpenEmbedded core) firefox works fine and It haven’t freezed yet, even if I change preferences in Firefox.
It have happened only with prepared image V2.5Beta2_20151106.

We do not believe this being possible but as you refuse to answer any of our questions concerning what exactly you are doing we are unable to assist you much further, sorry.

First, I prepared your image to uSD card - 2GB (formatted as fat32):
“sudo tar -xvf Colibri_iMX6-LinuxImageV2.5Beta2_20151106.tar.bz2”

then “cd /folder_with_extracted image/”
“./ -o /media/user/5D16-29F4”

then wait until everything is done - with no errors or warnings (it takes few minutes) - and until I get “Successfully copied data to target folder.”

then plug SDcard into Toradex Iris board SD card holder, plug in power and over serial terminal on laptop, then hit any key to stop autoboot and write:
“run setupdate” - wait until everything is done and I get:
“enter ‘run update’ to update the entire module”

So I write:
“run update”
and wait until all blocks are written OK and until system restarts.

Then I click on firefox, close it and reboot board.
After reboot I’m able to run firefox again with no problems.

Then I go in Firefox to Edit->Preferences and change Startup from “Show my homepage” to “Show my windows and tabs from last time” and check “Don’t load tabs until selected”.
Then I choose in downloads “Always ask me where to save files”
In Privacy check “Tell websites I do not want to be tracked” and choose “Never remember history”
In Security uncheck “Remember passwords for sites”
In Advanced check “Use smooth scroling”.

After system restart now it’s everything good.

Now I can’t manage to get this freeze again, don’t know why, but now it’s everything working. But before that I have “run update” this image for three times and there used to get firefox freezed.
So for now, everything is good. If it will freeze again, I’ll try to describe you what I was changing.

Note that the GLib assertion (process:780): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed appears even on successful starts, so this message seems to be unrelated to your issue.