HAB vulverability for Colibri iMX7D 1GB

Hello everyone,

We are starting a project with the SoM Colibri iMX7D 1GB v1.1A and we’d be interessed in using the secure boot feature.
We’d like to ask if this SoM is still affected by the vulverability explained in this errata: https://docs.toradex.com/103543-colibri-imx7-errata.pdf

By looking at this article, seems that it hasn’t been scheduled a fix in the future
https://developer.toradex.com/knowledge-base/secure-boot-vulnerabilities-for-imx-vybrid-errata-err010872-err010873

Thank you in advance,

Luca

@lupo, thanks for your question. The Colibri iMX7D 1GB V1.1A came a bit later than our other i.MX 7 based products. We used the affected SoC for some early prototypes and first samples. We switched to the SoC which had the HAB issue fixed in Q2 2018 when we ramped up the production. Except for the early samples, the Colibri iMX7D 1GB don’t have the HAB vulnerabilities.
We will update the respective information on our website and in the errata to make this clear.
Let me know if you have any further questions.

Hi @roman.tx,
thanks for your reply.
The SoM that we purchased in 05/2018 has this SoC code aboard: MCIMX7D5EVM10SC
The silicon revision is the 1.2, the one affected by the vulnerability.
Good to know that new SoMs have been upgrated!
Luca