Gst-launch-1.0 output on TK1 module using ixora carrier board

I was running this command using ubuntu 14.04 L4T

gst-launch-1.0 rtspsrc location=rtsp:// latency=10 ! decodebin ! autovideosink

it has opened a window to view the video on the 10 inches capacitive touch screen.
now for some reason my touch screen is not working; maybe it is broken. but the video is not appearing on a HDMI.
am I missing something?
what is the default output for this command? HDMI/LVDS ports?
how can I let gst-launch-1.0 tool to open the video on HDMI screen?
my screen when i run the bin file for the same command via c code

root@tegra-ubuntu:~/Desktop/stream_only# ./stream
Inside NvxLiteH264DecoderLowLatencyInitNvxLiteH264DecoderLowLatencyInit set DPB and MjstreamingNvMMLiteOpen : Block : BlockType = 261
TVMR: NvMMLiteTVMRDecBlockOpen: 5149: NvMMLiteBlockOpen
NvMMLiteBlockCreate : Block : BlockType = 261
TVMR: cbBeginSequence: 668: BeginSequence  704x480, bVPR = 0
TVMR: cbBeginSequence: 923: DecodeBuffers = 17
TVMR: cbBeginSequence: 947: Display Resolution : (704x480)
TVMR: cbBeginSequence: 948: Display Aspect Ratio : (704x480)
TVMR: cbBeginSequence: 1052: SurfaceLayout = 3
TVMR: cbBeginSequence: 1082: NumOfSurfaces = 21, InteraceStream = 0, InterlaceEnabled = 0, bSecure = 0, MVC = 0 Semiplanar = 1, bReinit = 1
Allocating new output: 704x480 (x 23), ThumbnailMode = 0
---> TVMR: Video-conferencing detected !!!!!!!!!

Hi @rama.aloufee !

Could you share the details of your setup?

  • Do you have more than one display connected to your module?

Also, have you tried using ximagesink or xvimagesink instead of autovideosink? Seems like with them it is possible to set the display.

Best regards,

Hi @henrique.tx

yes , HDMI and LVDS ( capacitive touch display)

I have tried
gst-launch-1.0 videotestsrc ! ximagesink
it worked properly

is not working

Hi @rama.aloufee !

I have tried
gst-launch-1.0 videotestsrc ! ximagesink
it worked properly


If this is enough, please, mark the message containing the solution to your issue.

If this is not enough, please explain what you need.

Best regards,

TK1 module is not able to run " gst-launch-1.0 videotestsrc ! autovideosink " or any command include " autovideosink " like:

gst-launch-1.0 rtspsrc location=rtsp:// latency=10 ! decodebin ! autovideosink

each type of image has its own problem.
1- when I install multimedia image " using easy installer standby image" , it tells that h.264 decoder is missing
I have installed gstreamer1.0-libav to solve that problem but when I run the command above, no video window appeared.

2- i have tried l4t image " using easy installer standby image" , also installed gstreamer1.0-libav, but again the same problem. no video window appeared.

Hi @rama.aloufee !

We carried out several pipelines on L4T Ubuntu 14.04 and HDMI and here is what we found out:

  • autovideosink uses nvoverlaysink under the hood. This nvoverlaysink, for some unknown reason it is not working.
  • Both ximagesink and nvhdmioverlaysink worked.

To force a pipeline to be displayed on a given display, you can set the environment variable prepending the pipeline command. Let’s say you need to show the pipeline on DISPLAY “called” :1. You can do like this:

DISPLAY=:1 gst-launch-1.0 videotestsrc ! nvhdmioverlaysink

To check the display name, you can execute an echo $DISPLAY on the serial terminal (usually, an SSH connection doesn’t set the DISPLAY environment variable)

Also, some of the elements are able to receive the display name as argument. You can check it using the gst-inspect-1.0 command, e.g.:

gst-inspect-1.0 nvhdmioverlaysink

Best regards,

Hi @henrique.tx,

Great, I will check it once I need it again.
now I am using ixora carrier board V 1.2 and it works fine with me.
the old ixora carrier board was V1.1 it is already have many problems



Let me know how it goes.

Best regards,