Graphical ui for Colibri Imx6DL with angstrom

Hello, world!

I have Colibri iMX6 with embedded linux installed. I have setup eclipse using the guides provided on the developer portal. I can compile apps that run in the console just fine.

However, I cant seem to find a clear path of what tools to use to create the ui. I have never developed any sort of ui for linux. I am well versed in OpenGL and SDL. One of the things I have tried is QT but I wasn’t able to set it up to cross compile.
I am very new to ARM development and whole cross-compiling aspect.

I was given this board as a prototype, its an IoT device that has a touch screen and will need a certain application to run which as asks user to enter certain information. This information will need to be passed to back end servers. This part I have working just fine, just not sure how to approach the ui part.

I am not asking somebody to hold my hand or spoon-feed me, I just want to know what tools people use to create user interfaces.

Language: c++
OS: Embedded linux Angstrom
Board: Colibri iMX6DL

Any help would be much appreciated!

Qt can be used for creating rich UI interfaces and setting up Qt is documented here. SDL is available in OpenEmbedded and can also be used. Another popular option might be GTK.

Thanks for the reply,

I think the version of embedded I have has been stripped to nothingness. Is there a way I can check what libraries are available to me? If SDL is part of the image, that would be awesome.

I have tried to dive into GTK, but i dont have a clue where I can’t get the header files, I tried downloding from their website and setup include directories but as it starts asking for cairo.h, cairo-features.h and I havent got a clue where to get them. Assuming that it is talking about cairo graphics library (once again, I have never developed at this level of linux)

For QT, I dont quite understand, it tells me I have to have embedded environment set up. Not quite sure what it does or what its for. I have followed this guide up to the Building stage. Once I try to build, at the very last step (or there abouts, around 7490 out of 7500) it errors out.

If i dont build and proceed with this guide when I try to compile my app using qt, I get the following error:
:-1: error: c: Command not found

Trying to do the same thing, but on an Apalix iMX6Q.

Is there a way to run an OpenGL program on it?

Thanks in advance!

You can check for the available libraries in our demo images or on any Linux system for that matter by checking /usr/lib. For example,

ls /usr/lib | grep -i "gtk"

To develop applications for the target, it would be recommended to set up OpenEmbedded and build the SDK as documented here. An example for Cairo application can be seen here.

OpenEmbedded is a build system used for customizing and generating complete images for flashing on the target which would comprise of bootloader, kernel, device tree blobs and root file system. It also allows generating SDK’s which can be used on host for developing applications for the target. The SDK would comprise of toolchain and required header files and cross compiled libraries.

What exact errors do you encounter during build with OpenEmbedded? Without any error logs, it is difficult to help.

We have some documentation here.