GPIO wakeup isn't working on TK1

I am following the instructions here to put the TK1 to sleep (LP1) and wake it up by toggling the WAKE_MICO pin (MXM3 PIN 37). I am unable to get the TK1 to wake up.

I have tried this before and it had worked last year. So I am guessing a different BSP version could be the culprit? I am on 2.7.5 L4T image with the default kernel and device-tree. Or do I need to setup anything else on the newer BSPs for GPIO to wake?

Or could this be related to the WOL issue?

Also as a data point, I am able to get the TK1 to wake up from LP1 using the SD Card detection (plugging in/out an SD Card)

did you try the bugfix for the WOL Issue?

Not yet. You reckon that solve this as well?

Could you try the Bsp 2.8b2 and check if this work please? Thanks.

Turns out the WOL fix did actually fix this one as well as both are just GPIO key wake-up sources and the GPIO key driver fails probing if any of its GPIO keys fails to request which was the case with the WOL one rendering WAKE_MICO unusable as well. You may just git cherry-pick the WOL fix into 2.7b5.

Thanks. Will try this out.

You are very welcome.

Any target dates for next TK1 L4T build with a 2.8x for Easy Installer? I would really prefer to avoid having to compile a custom kernel and I’m really liking the Easy Installer.

The official Q2 release is due June 30 (see our support strategy) but for testing you may soon find CI builds with that fix in our continuous integration feed.