GPIO export error in apalis tk1 with ixora 1.1

I have tried exporting and doing echo for gpio 250,248,237,238 and 234 in x27 port.
But when i tried the same for gpio108,109 and 233 of same x27 port, it shows “echo : write error : Device or resource busy”

Also how to find linux gpio numbers of x14 port?? i compared the ixora datasheet and apalis datasheet to find linux gpio numbering.Out of that only gpio224 worked.

whats the reason behind these errors?

I’m not sure whether or not you do know how to get to your Linux kernel GPIO numbers. First things first. The currently reserved GPIOs may be found by doing cat /sys/kernel/debug/gpio. To get to the number you first consult resp. carrier board datasheet which tells you what connector pin goes to which MXM3 resp. SODIMM module edge connector pin. Then you consult the module’s datasheet telling you which module edge connector pin goes to what SoC ball resp. GPIO. And finally, you consult the following table which gives you the Linux kernel GPIO number for resp. SoC GPIO. You may found some more information about GPIOs here as well.