GNSS SDR running on Ixora with NVIDIA Jetson TK1

Technical Support queries
I am trying to install the GNSS SDR on Ixora running the NVIDIA Jetson TK1, however it says that gnuradio 3.7.2.1 has to be updated to a higher version. When I try to install a newer verstion, it says that the boost installed is 1.54.0 and it requires at least boost 1.69. Any advices to solve this, please?

Hi @alexbvo2 ,

Can you please share with us more information? Which company do you work for? What is the OS are you currently running?

About the boost version, did you try to upgrade it? Which problems did you face?

Best regards,
Daniel Morais

Dear Daniel,

Thank you for your quick reply. The OS currently being use is the “Ubuntu 14.04.6 LTS, Trusty Tahr”, installed accross the Toradex Easy Installer and choosing the
NVIDIA Linux Jetpack TK1. See below the hardware details:

    SoM - Apalis TK1 V1.2A 2GB
     Carrier Board - Ixora V.1.2A
      Target Device OS - The installation of the OS NVIDIA Linux Jetpack TK1 on Ixora was performed using the Toradex Easy Installer 
      and on terminal it shows linux version "Ubuntu 14.04.6 LTS, Trusty Tahr".

My objective is to build from source the GNSS SDR (Build and install GNSS-SDR - GNSS-SDR) using the following command:
Command1: “$ cmake -DENABLE_CUDA=ON …/ && make && sudo make install”

It allows the use of CUDA with the GPU installed
Howerver, when I perform the Command1 it says that the gnuradio has an old version:

               CMake Error at cmake/Modules/FindGNURADIO.cmake:264 (message):
               GNU Radio v3.7.3 or later is required to build gnss-sdr.

When I try to upgrade the gnuradio version it says that the boost version is old also. However I didnt have sucess in upgrading the boost pack.
Could NOT find Boost: Found unsuitable version “1.54.0”, but required is at
least “1.69” (found /usr/include, found components: date_time

Below you can see the entire log.d

ubuntu@ubuntuhost:~$ cat /etc/os-release
NAME=“Ubuntu”
VERSION=“14.04.6 LTS, Trusty Tahr”
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME=“Ubuntu 14.04.6 LTS”
VERSION_ID=“14.04”
HOME_URL=“http://www.ubuntu.com/
SUPPORT_URL=“http://help.ubuntu.com/
BUG_REPORT_URL=“Bugs : Ubuntu
ubuntu@ubuntuhost:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.6 LTS
Release: 14.04
Codename: trusty
ubuntu@ubuntuhost:~$ hostnamectl
Static hostname: ubuntuhost
Pretty hostname: UbuntuHost
Icon name: computer
Chassis: n/a
Boot ID: 6d444cc9ab164ab6a81137005a43d8da
Operating System: Ubuntu 14.04.6 LTS
Kernel: Linux 3.10.40-2.8.6+g2c7a3c3af726
Architecture: armv7l

ubuntu@ubuntuhost:~$ cd Downloads/
ubuntu@ubuntuhost:~/Downloads$ cd work/
ubuntu@ubuntuhost:~/Downloads/work$ cd gnss-sdr/
ubuntu@ubuntuhost:~/Downloads/work/gnss-sdr$ cd build/

ubuntu@ubuntuhost:~/Downloads/work/gnss-sdr/build$ cmake -DENABLE_CUDA=ON …/ && make && sudo make install
– Configuring GNSS-SDR v0.0.17.git-next-c7eeeb0 to be built on
GNU/Linux Ubuntu 14.04 (32 bits)
– Build type set to Release.
– Checking for module ‘gtest’
– No package ‘gtest’ found
– Checking for module ‘orc-0.4 > 0.4.22’
– No package ‘orc-0.4’ found
– Checking for module ‘uhd’
– No package ‘uhd’ found
– Could NOT find UHD (missing: UHD_LIBRARIES UHD_INCLUDE_DIRS)
– Checking for GNU Radio Module: RUNTIME
– * INCLUDES=/usr/include
– * LIBS=/usr/lib/arm-linux-gnueabihf/libgnuradio-runtime.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-pmt.so
– GNURADIO_RUNTIME_FOUND = TRUE
– Checking for GNU Radio Module: PMT
– * INCLUDES=/usr/include
– * LIBS=/usr/lib/arm-linux-gnueabihf/libgnuradio-runtime.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-pmt.so
– GNURADIO_PMT_FOUND = TRUE
– Checking for GNU Radio Module: BLOCKS
– * INCLUDES=/usr/include
– * LIBS=/usr/lib/arm-linux-gnueabihf/libgnuradio-blocks.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-runtime.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-pmt.so
– GNURADIO_BLOCKS_FOUND = TRUE
– Checking for GNU Radio Module: FFT
– * INCLUDES=/usr/include
– * LIBS=/usr/lib/arm-linux-gnueabihf/libgnuradio-fft.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-runtime.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-pmt.so
– GNURADIO_FFT_FOUND = TRUE
– Checking for GNU Radio Module: FILTER
– * INCLUDES=/usr/include
– * LIBS=/usr/lib/arm-linux-gnueabihf/libgnuradio-filter.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-fft.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-runtime.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-pmt.so
– GNURADIO_FILTER_FOUND = TRUE
– Checking for GNU Radio Module: ANALOG
– * INCLUDES=/usr/include
– * LIBS=/usr/lib/arm-linux-gnueabihf/libgnuradio-analog.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-runtime.so;/usr/lib/arm-linux-gnueabihf/libgnuradio-pmt.so
– GNURADIO_ANALOG_FOUND = TRUE
– The GNU Radio version installed in your system (v3.7.2.1) is too old.
Go to GitHub - gnuradio/pybombs: PyBOMBS (Python Build Overlay Managed Bundle System) is the GNU Radio install management system for resolving dependencies and pulling in out-of-tree projects.
and follow the instructions to install GNU Radio in your system.
CMake Error at cmake/Modules/FindGNURADIO.cmake:264 (message):
GNU Radio v3.7.3 or later is required to build gnss-sdr.
Call Stack (most recent call first):
CMakeLists.txt:619 (find_package)
– Configuring incomplete, errors occurred!
See also “/home/ubuntu/Downloads/work/gnss-sdr/build/CMakeFiles/CMakeOutput.log”.
See also “/home/ubuntu/Downloads/work/gnss-sdr/build/CMakeFiles/CMakeError.log”.

ubuntu@ubuntuhost:~/Downloads/work/gnss-sdr/build$ cd ~
ubuntu@ubuntuhost:~$ cd gnuradio/

ubuntu@ubuntuhost:~/gnuradio$ cd build/
ubuntu@ubuntuhost:~/gnuradio/build$ ls
CMakeCache.txt CMakeFiles
ubuntu@ubuntuhost:~/gnuradio/build$ cmake
-DCMAKE_C_FLAGS=“-march=armv7-a -mthumb-interwork -mfloat-abi=hard
-mfpu=neon -mtune=cortex-a15” -DCMAKE_ASM-ATT_FLAGS=“-march=armv7-a
-mthumb-interwork -mfloat-abi=hard -mfpu=neon” …/
– Build type set to Release.
– Build date set to Fri, 25 Nov 2022 15:22:57Z.

– The build system will automatically enable all components.
– Use -DENABLE_DEFAULT=OFF to disable components by default.
– Extracting version information from git describe…
CMake Error at /usr/local/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:230
(message):
Could NOT find Boost: Found unsuitable version “1.54.0”, but required is at
least “1.69” (found /usr/include, found components: date_time
program_options system regex thread unit_test_framework chrono atomic)
Call Stack (most recent call first):
/usr/local/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:592
(_FPHSA_FAILURE_MESSAGE)
/usr/local/share/cmake-3.20/Modules/FindBoost.cmake:2344
(find_package_handle_standard_args)
cmake/Modules/GrBoost.cmake:111 (find_package)
CMakeLists.txt:62 (include)