Git error while cloning kernel source

Hi community,
I tried to clone the kernel source code in my PC by using

git clone -b toradex_4.9-2.3.x-imx git://

But it gets stuck either after 99% of receiving objects or after completing resolving deltas.I tried with http and https instead of git but that didn’t even go for remote:counting objects. I also tried this with my colleague PC and the same result occurs. Does the same issue occurred to anyone? Any suggestions to resolve this issue is appreciated.

fatal: read error: Connection reset by peer1.72 GiB | 4.77 MiB/s

fatal: early EOF

fatal: index-pack failed

This is the error I am getting after sometime.

Thanks and regards,

Actually we have 2 mirrored git servers one in Europe - and one in US -
I’ve tested them and cloning of toradex_4.9-2.3.x-imx was successful on both. Most likely you have a problem with your Internet provider. Could you try to use git1 and git2 may be one of them will work better for you. If it will not help - can you try to use different Internet provider?

Hi @alex.tx ,
Thanks for your quick response, solved my issue.

HI @nishanth1829

Perfect that the issue is solved. Thanks for the feedback.

Best regards,