Getting "Unable to create child process in new job" error after Windows Update

Hi All,

After installing the latest updates on Windows 10 my platform builder for WEC7 or WEC2013 stopped working.
When I try to build an image I get error:

PBSpawn: error: Current process is running in a job that does not allow breakaway. Unable to create child process in new job.

Did you notice something similar and maybe found a solution?


When using Windows 10 Microsoft Version 10.0.17763.379 in combination with update KB4493509 we also see same error. Removing update KB4493509 fixes the issue but this is not recommended way of doing it.

Hi Toradex,
I have some good news.
I was planning on uninstalling each Windows (Security) Update one after the other; rebooting; then trying the CE 7 build using VS2008 on each pass. However, after the most recent update was uninstalled and the system restarted there was a new update installed. Since updates are being forced onto the PC beyond my control, I tried the CE build and lo-and-behold it started. :slight_smile:

The Win 10 x64 PC is running build 17763.404 - Version 1809.
Removed Windows update: KB4490481 2-May-19. (It’s unknown if just this was the root cause)

Windows update that appears to fix the problem: KB4476976, 3-May-19

Update: Just to be sure I reinstalled KB4490481; Reboot; Run CE Build - PBSpawn error - FAIL

Uninstall KB4490481; Reboot; Run CE Build - SUCCESS.

Conclusion: The error appeared long before KB4490481 was installed (yesterday). So there’s more dynamic to this than meets the eye. Perhaps a combination of the two aforementioned updates that resolves this issue.

I sincerely hope that my efforts help out others. Thank you so much for your help.

Best regards,


I could successfully build a platform solution by opening an Administrator CMD and pasting the path to devenv.exe. Directly starting VS2015 from the taskbar did not allow to build the solution, it failed with the PBSpawn error.

Environment: Win10 64 bit 1809 (OS Build 17763.439), with no installed Updates KB447xxxx and two installed Updates KB449xxxx (5590 and 9728), VS2015 Pro Versin 14.0.25431.01 Update 3

Dear @zorro
Thank you for the report.
Regards, Andy

WORKAROUND (found by MVP Minsung Kim):

  1. Apply all updates (do not uninstall any)
  2. Run Visual Studio 2015 and open your WEC2013 OS Design -or-
    Run Visual Studio 2008 and open your WEC7 OS Design
  3. Build your OS Design
  4. If it builds; hooray, all good! If it doesn’t, continue below:
  5. Click Start → Restart to reboot your machine
  6. When Windows 10 comes up again, it will automatically start VS and load your OS Design.
  7. Now build your OS Design
  8. It should build just fine.

Next time you reboot your PC (without VS running), you will get the PBSpawn error back, so this is definitely not a solution but just a temporary workaround until Microsoft releases another update that fixes the problem for good.