Getting continous message of pixclock=25200000 Hz [ 27.503559] mxc_sdc_fb fb.20: 640x480

I created an fresh setup of Apalis iMX6 Yocto using the steps mentioned in the documentation.
I am able to flash the build kernel image on the SD card and boot the board .

( Board is connected with an HDMI to VGA converter. The setup was proper with default factory flashed image )

But the setup throws below mentioned console message on the screen & I am not getting any display.

root@apalis-imx6:~# uname -a

Linux apalis-imx6 3.14.52-v2.6.1b1+g3894f6d #1 SMP Thu Jan 12 16:22:15 IST 2017 armv7l GNU/Linux

root@apalis-imx6:~# 
[ 27.442270] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 pixclock=25200000 Hz 
[ 27.503559] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 pixclock=25200000 Hz 
[ 27.574334] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 pixclock=25200000 Hz 
[ 27.643510] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 pixclock=25200000 Hz 
[ 27.713798] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 pixclock=25200000 Hz 
[ 33.232863] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 pixclock=25200000 Hz 
[ 33.293524] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 pixclock=25200000 Hz 
[ 33.364302] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 pixclock=25200000 Hz 
[ 33.433497] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 pixclock=25200000 Hz 
[ 33.503789] mxc_sdc_fb fb.20: 640x480 h_sync,r,l: 96,16,48 v_sync,l,u: 2,10,33 

Could members please guide me as to what might be the probable cause as I am unable to access the console terminal due to these message & the HDMI output is also not working .

Hi Toradex Team ,

Any inputs on this .

Are you one of them impatient types?

First a few questions for clarification:

  1. The factory default image you mentioned was probably of an older BSP version then the one you now built. Would you know what version that was exactly?
  2. How about DDC/EDID of your HDMI to VGA converter, does it properly provide that?
  3. Have you tried a regular HDMI screen at all?
  4. Have you tried any of the suggestions like e.g. the following?

Sorry Marcel ,

Was not intending to violate rules of forum. Since we are working with Apalis iMX6 & Yocto for the first we wanted to have the default setup up as soon as possible as that could help us to focus on our actual project requirement .

w.r.t your query please find below details :-

  1. I had flashed the default image with the one which we created at our end , hence dont have the default version. But i can share the current one.

    The Angstrom Distribution apalis-imx6 ttymxc0
    Angstrom v2014.12 - Kernel 3.14.52-v2.6.1b1+g3894f6d
    Apalis_iMX6_LinuxImageV2.4_20150518

  2. After observing the problem we procured an HDMI monitor & now dropped the usage of HDMI-VGA as pointed. But even with HDMI monitor being connected to board now ( no hdmi to vga convertor) , i am not getting the display. The error log continues to fill the console .

  3. I am going through it & will share the result.

Marcel , on parallel if possible do let us know if this is an known behaviour & how is this addressed

Thanks.

Can you try with the latest image please from here? For information on flashing the modules, refer here.

Dear Sanchayan ,

  1. Using the latest release we are getting the display with below mentioned message (only once on console )

  2. The latest release has different ( latest) Angstrom & Apalis image.

Angstrom v2015.12 - Kernel 3.14.52-v2.6b2+g7c83cef

Apalis_iMX6_LinuxImageV2.6_20160630

  1. Am i missing any aspect as i was expecting the image created when compiled at our end would be the latest release…
    I checked the build/conf/local.conf and it has entry for 2015.12 version of angstrom …My conf is link text

link text

The latest release is 2.7 Beta 1 with 4.1 kernel. OpenEmbedded would require a repo synced to “LinuxImageV2.7” to have the latest image. We are in the process of updating the documentation, so the OE article still does not reflect this. Does the 2.6 image solve your issue?

Dear Sanchayan ,

I am not getting "ADD COMMENT " arrow over your last comment , hence replying in this mode.

Please dont consider this as answer & close .

Yes Apalis_iMX6_LinuxImageV2.6_20160630 looks proper , i have started an fresh installation once again
( this i started before your reply to cross check if i am doing any steps wrong )

Also any rough idea as to by when we can have the documentation updated so that we can proceed ahead.

Instead of

repo init -u http://git.toradex.com/toradex-bsp-platform.git -b LinuxImageV2.6.1

use

repo init -u http://git.toradex.com/toradex-bsp-platform.git -b LinuxImageV2.7

to initialize the repo for OE and you should be able to build latest version of things.

Ok Sanchayan ,
Will test the changes suggested and let u know the outcome

Dear Sanchyan ,

We are getting below mentioned error using the step mentioned.

ERROR: firefox-38.8.0esr-r0 do_compile: oe_runmake failed

ERROR: firefox-38.8.0esr-r0 do_compile: Function failed: do_compile (log file is located at /home/ashish/oe-core/build/tmp-glibc/work/armv7ahf-neon-mx6qdl-angstrom-linux-gnueabi/firefox/38.8.0esr-r0/temp/log.do_compile.22207)

ERROR: Logfile of failure stored in: /home/ashish/oe-core/build/tmp-glibc/work/armv7ahf-neon-mx6qdl-angstrom-linux-gnueabi/firefox/38.8.0esr-r0/temp/log.do_compile.22207

To ensure the stepup is clean , i removed the entire setup & tried with fresh setup .
But the problem still is present.

The detailed log is attached here link text

Are all prerequisites installed as per here. Can you provide the log files for tasks that failed which would be

ERROR: Function failed: do_compile (log file is located at /home/ashish/oe-core/build/tmp-glibc/work/armv7ahf-neon-mx6qdl-angstrom-linux-gnueabi/firefox/38.8.0esr-r0/temp/log.do_compile.22207)
RROR: libarchive-native-3.2.2-r0 do_compile: Function failed: do_compile (log file is located at /home/ashish/oe-core/build/tmp-glibc/work/x86_64-linux/libarchive-native/3.2.2-r0/temp/log.do_compile.10932)
ERROR: Logfile of failure stored in: /home/ashish/oe-core/build/tmp-glibc/work/x86_64-linux/libarchive-native/3.2.2-r0/temp/log.do_compile.10932

Yes the prerequisites were already installed during the installation of repo init -u http://git.toradex.com/toradex-bsp-platform.git -b LinuxImageV2.6.1

The only thing i changed now is tried all the steps of oe-core installation to get the fresh setup using repo init -u http://git.toradex.com/toradex-bsp-platform.git -b LinuxImageV2.7

w.r.t log , i have attached in the comment posted today as oecore_log.tar.bz2 as the log file by itself is around 11MB. Just to give you confidence that the prerequisites are installed , i tried to install them back. Since those were already installed none of the packages were installed this time , as they were already present . Attached is the log .link text 1: https://share.toradex.com/fzzryhd3za0x0es?direct

w.r.t log.do_compile.10932 its is attached here link text

You can let me know if you want any other log or any file .

Can you provide the two logs separately, the one for Firefox

/home/ashish/oe-core/build/tmp-glibc/work/armv7ahf-neon-mx6qdl-angstrom-linux-gnueabi/firefox/38.8.0esr-r0/temp/log.do_compile.22207

and the one for libarchive

/home/ashish/oe-core/build/tmp-glibc/work/x86_64-linux/libarchive-native/3.2.2-r0/temp/log.do_compile.10932

The combined log has too much data to parse easily.

Attached here are both the files in tar.bz2 format as individual size are large.
link text

link text

I don’t see the one for Firefox 22207. 10932 is attached twice?

Both the tar,bz2 are proper in the above link , still adding them individually to save your valuabe time & effort
log.do_compile.22207
link text

log.do_compile.10932
link text

Dear Sanchayan ,
Any inputs to solve this problem …
I tried with fresh build but the problem still persist.