Ftrace on apalix-imx8

I am trying to enable Ftrace on the OpenEmbedded build for apalis-imx8. I found this question: ftrace on imx7 - Toradex Community which describes a way to enable the necessary configs.

Unfortunately, when I issue

MACHINE=apalis-imx8 bitbake -c menuconfig virtual/kernel

I get a lot of undefined reference errors on the terminal that opens for menuconfig (error.log). I’m not sure how to fix this.

Does the ftrace-on-imx7 question contain the correct method for enabling Ftrace? Is there another method?

Could you please provide your build log as an attachment.

Here’s the build log from me running MACHINE=apalis-imx8 bitbake -c menuconfig virtual/kernel 20200603203101.log

Did you try to do a “regular” build with unmodified config?

I have not made any direct kernel configuration changes. I only have some modifications in my bulid/conf/local.conf and have successfully built for apalis-imx8 with them (via bitbake -k console-tdx-image ).

I am unable to make direct kernel configuration changes because the menuconfig “recipe” fails. This recipe looks to open menuconfig in another terminal tab, the build log for that is attached to my original question as error.log. My full build log is attached to my previous comment as 20200603203101.log.

Could you try to build image exactly as described here with no modification?

I have build an image like this previously. My only modification was selecting apalis-imx8 in build/conf/local.conf.

I also tried deleting my local.conf, setting it to default via . export and then re-running bitbake -c menuconfig virtual/kernel. I encountered the same error.

I followed the guide exactly and still got the errors when running bitbake -c menuconfig virtual/kernel

HI @fettersa

Which Linux Distribution are you using on your host?

Best regards,
Jaski

I’m using an Ubuntu 18.04 64bit VM.

alex@rogueVM:~$ uname -a
Linux rogueVM 5.3.0-59-generic #53~18.04.1-Ubuntu SMP Thu Jun 4 14:58:26 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

I’be made fresh installation of Ubuntu 18.04 on a latest version of Oracle VM and than follow instruction from this article. And image was built successfully. Could you try to do a fresh Ubuntu VM?

I created this VM for the express purpose of building the OpenEmbedded image, so this is a fresh installation of Ubuntu 18.04 running on Oracle VM VirtualBox 6.0.22 r137980. I’ve only installed tools described in that guide plus a couple others like VIM.

I am not having issues building the image. I have recently built using the bitbake -k console-tdx-image on tag Apalis-iMX8_Console-Image_3.0b4.254-20200421. I have also built with modifications to my conf/local.conf. The state I am now is I have reverted my conf/local.conf to only select Apalis-iMX8 and accept the FSL EULA. I then rebuilt console-tdx-image with the “stock” conf/local.conf.

What I am having issues with is the recipe that launches menuconfig so that I can configure the kernel. Can you confirm that you are able to launch menuconfig via bitbake -c menuconfig virtual/kernel?

Hi

For launching bitbake -c menuconfig virtual/kernel, uncomment and set OE_TERMINAL = "screen in local.conf. For this, the package screen must be installed on VM Ubuntu 18.04.

Best regards,
Jaski

I made the suggested modifications to my conf/local.conf and tried running the bitbake command with and without the MACHINE=apalis-imx8. I installed screen via apt-get install screen and the behavior did change. It no longer launches another terminal tab, but the failure is the same: I am still unable launch menuconfig. See the error.log in my original post.

Installing libncurses5-dev solved my issue. Missed that on the question I linked. Good catch!

Hi @fettersa

Sorry for the delayed answer.

I tried also on my side to compile this and the compilation is working fine.

Did you install the following package: libncurses5-dev ?

Best regards,
Jaski

Perfect that the issue is solved. Thanks for the feedback.

Best regards,
Jaski