FTP on WEC2013

Hi,
today I tried to connect to the iMX7d, running WEC2013 using the ftp-protocoll, but no chance.

To keep things simple for the moment, I enabled anonymous access in the registry using this infos:
https://docs.microsoft.com/en-us/previous-versions/windows/embedded/ms881875(v=msdn.10)
Infortunately I get a connection error.
Yes, the address of the module is correct and yes, I also tried from a WinXP maschine to overcome some security protocol issues.

Here my last settings, but I tried a lot others before, and yes, the directory exists and contains files …

alt text

With best regards

Gerhard

Hi @Gerhard ,

I did a quick test and i’m able to access the FTP server with the same settings as yours.

Here is my input/output in on the FTP tool on the PC side:

C:\>ftp 10.0.0.103
Connected to 10.0.0.103.
220 Service ready for new user.
500 Syntax error, command unrecognized.
User (10.0.0.103:(none)): anonymous
331 Anonymous access allowed, send identity (e-mail name) as password.
Password:
230 User logged in, proceed.
ftp>

Can you send the exact error output you get?
NOTE: Only Anonymous access will work with your settings, If you want to do some kind of authentication then you need to set-up User Names and Passwords. Normally this is done in the Web Interface, but since MS decided to remove it on CE8 this needs to be done programmatically by using NTLM Apis, see:

https://docs.microsoft.com/en-us/previous-versions/windows/embedded/ms926215(v%3Dmsdn.10)

Hi Germano,

thanks a lot.
As registry settings normally working immediately, this isn’t true for the ‘IsEnabled’ setting of the ftp server.
On my SoM the ftp server was disabled and I have to start it. But I didn’t know, that I have to restart the OS.

After a restart the ftp starts working.

Did I really have to do it programmatically, there is a ‘UserList’ setting in the registry, but yes, I can’t find a place for setting the pass words.

With best regards

Gerhard

oops, the link you provided is dead.

And I found out, that I can access the files, but I cant delet them …

With best regards

Gerhard

Hi Gerhard,

I corrected the Link.

Best regards,
Jaski

Did you try AllowAnonymousUpload=1 to see if it will also allow deletion?
Bu it could be that this is not possible with anonymous mode
To Add users to the system you need to use the NTLMSetUserInfo() This will add some encrypted registry settings that you cannot edit directly.
The UserList registry setting is just limiting FTP access to the specificed users, but they need to be added to the system first.