FlashDisk error after create an EAP-PEAP wireless Connection

We are working with an iMX6DL mounted on our carrier board, which integrates a LM823 wifi module that connects through a USB HUB connected to the USB Host of the iMX6DL.

We have worked with networks with WPA2-PSK security without problem.
But yesterday we tried to set up a NETWORK with WAP EAP-PEAP authentication and the following happened to us

The certificate .cer was first imported from the control panel/certificates, then the connection was configured from the windows CE interface.
We use AES encryption, WPA authentication and EAP-PEAP, in the properties window we check the box “validate with the server”. We tried to connect, we entered the credentials but the connection failure message came out.
We repeat the same process but now we uncheck the box “validate with the server” we entered the credentials and the connection was successful.

We tried the connection to the server and it worked correctly. We save the registry and restart to check if the password was saved, when starting the device again the touch did not work, the driver of the wifi module was not recondicted, the wallpaper was lost and our application that was in the folder AutoRun did not start automatically . I attach a photo of this. alt text

Checking why this happened we realized that in My Device the flashdisk appeared as a normal folder and created another instance called flashdisk2 where all the system files, drivers and applications were found, therefore nothing worked alt text

We thought that it was a specific error but we repeated it in 4 different devices and in all the same thing happened.

We continue testing and detect that this happens with or without the certificate installed and it occurs when you connect or try to connect to a NETWORK with the WPA EAP authentication and then reboot

Do you know the reason why this happens? And what would be the possible solution?
When this happens, the only way to recover the device is to reflash or clean the registry.

Can you please enable output on debug serial port to check for error messages during boot?
There was an issue restoring the filesystem via update tool in v.1.3, are you currently using this feature?
Can you please provide us a step by step guide to reproduce the issue, including any extra driver you have to setup on the device?


I have observed the same issue this morning.
Yesterday I try to connect my iMX6 device running WEC2013 to a share folder of my laptop. It works sucessfully.
When I enter the login and password I check the box to remember the credentials.

Then at next start of the device I had a FlashDisk classic folder and a FlashDisk2 disk with all the data previously stored on the Flashdisk drive.

Do you have an idea how to recover from this issue without flashing the device?
Do you know how to avaoid this issue?

Thank you in advance.

It seem that something tries to access the \FlashDisk folder early at boot. We mount it asynchronously in the new release, to reduce boot time, but this seem to generate an issue with some components that store their own configuration data there.
Can you try to set:


In your registry and save it?
That should load the driver required to mount \FlashDisk early during boot and this should fix the issue.