File system corruption

Colibri iMX6S 256MB V1.1A
Colibri evaluation board V3.1A
WinCE 1.6

Trough the years of development we had problems with database corruption, later on we started losing files.
So we ran an investigation and found out, that it is related to reading/writing files on file system, immediately after windows lunches the application.

Reading a file just fails, but writing to a file can lead to a serious file system damage, entire file system can be wiped out.

To isolate the problem we wrote a simple application, that just reads and writes to some files.
This application was put on root of FlashDisk and auto ran trough the LunchXX registry.
With each test the application gets corrupted. We get an error …is not a valid windows embedded compact application.
Test was ran on new module with WinCE downloaded and installed trough Tezi, on eval. board.

We are about to lunch a new product, but first we need to somehow solve this serious issue. Any help would be much appreciated.

Best Regards,

Dear @piseek ,

Can you try to disable the eMMC Trim feature like described here:

We think this feature might be responsible for the strange behavior

Hi Germano,

Thank you for quick reply.
Yesterday I found a similar post:

I first tried to disable L2Cache, it looks like the problem disappeared.
I will also try disabling Trim feature and make some tests.

Could you please tell me, what is the downside of each solutions and which is preferred?

Best regards,

Now I did some testing with Trim disabled…

  • Our main application ran on 3 instruments, 3.000 reboots on each and not a single fault was found.

  • It also solved the problem with damaging the test application. But the application will not start.

To me it looks better to disable L2 cash, or should I disable both features, to be on the safe side.
I would really appreciate your advice.

Best Regards,

You may want to check this option “TransactData”=dword:0|1