Fetch code from svn repo brings E215004: No more credentials or we tried too many times


we developed our own Qt application with the Qt Creator and an SDK built with yocto and BSP6.
An SVN repository with login access on a company server is used for software versioning.

To add the Qt application to our image, I created a recipe to generate it from the source code when building the image.
Therefore I set the SRC_URI to the following:

SRC_URI = "svn://<repo_path>;module=<name>;protocol=http;rev=HEAD"

But fetching fails with the following error:

/usr/bin/env svn --non-interactive --trust-server-cert co --no-auth-cache --ignore-externals -r HEAD http://<repo_path>/<name>@HEAD <name> failed with exit code 1, output:
svn: E170013: Unable to connect to a repository at URL 'http://<repo_name>/<name>'
svn: E215004: No more credentials or we tried too many times.
Authentication failed

The credentials for the SVN repository are stored on my build machine under ~/.local/share/keyrings/Default.keyring
When I call the first line of the error output in a console in the home directory of my build machine the repository is checked out correctly.

Why doesn’t yocto use the saved login data?

Best regards,

Hi @Mowlwurf,

I don’t know if it’s to your satisfaction, but in an old project of ours we used a recipe to checkout our SVN sources as follows:

SRC_URI = "svn://<repo_path>;module=trunk;protocol=https;user=${MY_SVN_USER};pswd=${MY_SVN_PASSWORT}"

The SVN credentials are stored (unfortunately unencrypted :face_with_raised_eyebrow: ) in the build/conf/local.conf like:


Kind Regard

Hi @buw3,

thank you for your message.

The solution is actually not very nice because the access data is saved in plain text. But it is the only one that works for now.

Best regards,