Failure to see output on M4 core

I’m having trouble seeing any output on the M4 Core. I’m using this guide as a reference: FreeRTOS on the Cortex-M4 of a Verdin iMX8M Mini
I’m currently trying to load the freertos_hello.bin file from the downloaded sdk. I’ve loaded it into the internal memory by putting building the file on my windows pc and copying it over into the linux mounted file system via usb drive.

[upload|zmcq8+gEJc+inUjLkrnJmSFayjU=]

This is the filesystem currently showing on my device. When I follow the commands in the guide, I get confirmation that the core is running, but I see nothing on the output.

[upload|n1ovXzo2nCzo5H9L8pLZn68VQpM=]

Any help would be greatly appreciated.

Greetings @JCDToradex!

I was able to run the FreeRTOS Hello World example by loading the compiled firmware using tftp, so we know that it should work.

I see that you tried to load the file with ext4load, but the correct partition type would be FAT as seen from U-Boot:

Verdin iMX8MM # mmc part

Partition Map for MMC device 0  --   Partition Type: DOS

Part    Start Sector    Num Sectors     UUID            Type
  1     8192            31072256        b1638886-01     83

So you’d need to use U-Boot’s fatload for that. Can you please give this a try?

Hi @gustavo.tx,

I can’t use fatload, the system declares it as unrecognizable, and only sees ext4load as usable.
2720-screnshot.png

Hi @JCDToradex!

I can reproduce this here. While I look for a solution, can you please check if loading the firmware from an ext4-formatted SD card (using ext4load) works?

I tried using both load methods (ext4load and fatload) with an sd card, and I still get the same issue, where it prints that the aux core is starting, but no output shows.

Any update on this? I still haven’t been able to find a solution.

Hi @JCDToradex!

Just tried this and it worked. I’ll describe the steps I followed so you can try to reproduce that on your side:

  • Formatted an SD card as FAT32

  • Transferred the compiled hello_world.bin firmware to the SD card

  • Insert SD card on Verdin Development Board (connector X55)

  • Turn on the board, stop boot and on the U-Boot (U-Boot 2020.04-5.2.0-devel+git.586f79f64f6a) prompt, run

    Verdin iMX8MM # fatload mmc 1 0x48000000 hello_world.bin && dcache flush && cp.b 0x48000000 0x7e0000 0x20000

    13572 bytes read in 16 ms (828.1 KiB/s)

    Verdin iMX8MM # bootaux 0x7e0000

    Starting auxiliary core stack = 0x20020000, pc = 0x1FFE030D…

On the M4 UART, I could see

hello world.

Let me know if that works for you.