Failure to bitbake torizon-core-docker

I am encountering an error while trying to build the write image for Torizon 6.5 for the Verdin iMX8M Plus using bitbake.

Two weeks ago, I was able to build successfully using the same environment and command.

[ERROR message]
bitbake_log.txt (4.4 KB)

| DEBUG: Executing shell function do_compile
| NOTE: Using rust targets from /home/share/work_dir/torizon6.5.0/build/tmp/work/cortexa53-tdx-linux/rac/0.0+gitAUTOINC+719afe6b829316c096b3-r0/rust-targets/
| NOTE: cargo = /home/share/work_dir/torizon6.5.0/build/tmp/work/cortexa53-tdx-linux/rac/0.0+gitAUTOINC+719afe6b829316c096b3-r0/recipe-sysroot-native/usr/bin/cargo
| NOTE: cargo build -v --offline --target aarch64-tdx-linux-gnu --release --manifest-path=/home/share/work_dir/torizon6.5.0/build/tmp/work/cortexa53-tdx-linux/rac/0.0+gitAUTOINC+719afe6b829316c096b3-r0/git//Cargo.toml
| error: failed to get `tough` as a dependency of package `rac v0.1.0 (/home/share/work_dir/torizon6.5.0/build/tmp/work/cortexa53-tdx-linux/rac/0.0+gitAUTOINC+719afe6b829316c096b3-r0/git)`
| Caused by:
|   failed to load source for dependency `tough`
| Caused by:
|   Unable to update
| Caused by:
|   can't checkout from '': you are in the offline mode (--offline)

Greetings @p-uchi,

Please see the solution in this other thread here: Rac error, bitbake unable to build - #4 by jeremias.tx

This appears to be the same issue you are having here. Please try again with the latest fix for meta-toradex-torizon.

Best Regards,

Hi, @jeremias.tx,
Thanks for your reply.
Your advice helped me solve the problem!

I replaced meta-toradex-torizon with the layer folder in the pull request and that solved the relevant error. Thanks for the support.

Glad I was able to help!

hi @jeremias.tx ,
I have just pulled the manifest for Torizon 6.5 and got the same error.
that’s what I have done:

$ repo init -u git:// -b kirkstone-6.x.y -m torizoncore/default.xml
$ repo sync --no-clone-bundle
$ source setup-environment
(select "verdin-imx8mm" as machine)
$ bitbake torizon-core-docker

I have manually checked recipes-sota/rac/ and the fix is not there.
could be that the manifest is pointing to the old revision of the layer?

<project name="meta-toradex-torizon" path="layers/meta-toradex-torizon" remote="torizon" revision="73d5c90113747abb1d4371f4f750493db8d2da81">

looking at the history of the branch Activity · torizon/meta-toradex-torizon · GitHub, it seems that the revision is 22 days old

@RoccoBr, I see you are using the default.xml manifest here. This manifest is only updated periodically with monthly and quarterly releases. It has not been updated yet to point to a more recent version of meta-toradex-torizon that contains this fix.

If you want this fix now without waiting for the default.xml to be updated by us. Just simply use git commands to manually update the meta-toradex-torizon repository in your build. That said a new month just started so I expect the default.xml to be updated soon once we’ve organized this month’s monthly release.

Best Regards,