[Failed] to start Network Time Synchronization

HI,

When i compile the kernel and modules, i am getting the following error at boot time.

[Failed] to start Network Time Synchronization

What is the reason of this error.

Best regards.

Hi @hyaldiz , how are you?

Thanks for your question. Before we try to answer your question in more detail, could you please share more information about your setup?

  • Which Colibri iMX6ULL model and version are you using?
  • Which Carrier Board and version are you using?
  • Are you building your own OS (Yocto) or are you using Torizon Core? Which Version are you using?
  • We understood that you might be customizing kernel and/or kernel modules and deploying them to your SOM and the problem occurs during boot. Is that right?
  • Could you please share the whole boot log that you’re getting?

Thanks!

Best Regards,
Guilherme

  • Colibri iMX6ULL 512MB Wi-Fi / Bluetooth IT
  • Iris Rev. 2.0
  • I am using Yocto prepared by Toradex.
  • Yes i made some changes on the kernel and this problem occurred.
    NOTE: Wifi connection has become difficult, could that be the reason?

boot_log (39.2 KB)

Dear @hyaldiz , thanks for the clarification.

  • Can you confirm just the Version of Module and Carrier Board? For instance: Colibri iMX6ULL 512MB Wi-Fi / Bluetooth IT V1.x Y | Iris Rev 2.0 A
  • Which Yocto Image did you based yourself ? The Toradex-Reference-Multimedia or Reference-Minimal?
  • In addition, as you’ve made some changes to the Kernel, could please do the same test on a standard Toradex Reference Image?
    • With this, if the only change that you made was in the kernel configuration while compiling your image, we may suppose that the problem lays in our .config file.

This can be linked to multiple factors. Are you using two antennas or only one? Are you away from the router? Did you change wifi configuration in the Kernel?

Best regards,
Guilherme

  • Colibri iMXULL MB WB IT V.A and Iris Rev 2.0A
  • It has been specially prepared by the image toradex technical support that I am currently using. This image works fine, but when i compile kernel and modules gives this error.
    I added Rotary Encoder driver and gpio keys, i didn’t change any wifi configuration.
  • I am using only one antenna for wifi.

Best Regards.

Hi @hyaldiz ,

Thanks again for the information.

What image do you refer to? The Toradex Reference Images for Yocto are either Reference Minimal or Reference Multimedia (Build a Reference Image with the Yocto Project/OpenEmbedded - Toradex System/Computer on Modules). There is also the option to build Torizon Core Images using Yocto (Build TorizonCore from Source With Yocto Project/OpenEmbedded).

In addition, can you please confirm that if while using an image from Toradex without any customization do you get the same error?

We usually suggest customers use the two antennas whenever possible. Using only one may reduce signal quality.

Best regards,
Guilherme

The image I use is specially prepared for us by toradex paid technical support.

I don’t get the same error without any customatizon.

Best regards.

Hi @hyaldiz ,

Thanks for replying and sorry for my misunderstanding on which image you were using. We’ll try to replicate your error on our side to come up with a solution.

Could please just share the steps you’re using to customize this image before you get that error? This way, we can have a better idea of what’s causing this issue.

Best regards,
Guilherme