Failed to connect to target linux with Eclipse Remote System Explorer

Hello,

After rebuilding image graphical-tdx-image fetched from LinuxImage4.0 branch (commit dated 30-06-2020) and loading that image into the Apalis IMX8 board, I cannot connect to it using the Eclipse Remote System Explorer.
It gives the error "Failed to connect sshd on “10.124.21.50:22” and in the details “Algorithm negotiation fail”.
I tried to connect with Tera Term ssh on the same IP and that works OK, I see the system prompt.
When using the default already built console image that is available from the toradex easy installer tool, then I can connect with Remote System Explorer. So I’m guessing it has to do with the rebuilt image. Any idea what is missing ?

Dear @Edouard ,

Greetings and Thank you for writing to Toradex Community!

At first glance, it looks like the version of com.jcraft.jsch doesn’t support the algorithm used in the SSH keys (maybe a latest version). Could you try to upgrade the version of jsch that your Eclipse is currently using? Here I found a thread that I think might be useful to you: https://www.eclipse.org/forums/index.php/t/1073999/

Can you also tell me, when you re-built the new image, did you also make some changes to the image?

Best Regards,
Janani

Hello @saijanani.tx,

Thanks for helping me. I had a look at my eclipse installation (which by the way is the latest release 2020-06) and it seems to ship with:
com.jcraft.jsch (0.1.55.v20190404-1902) "JSch

From what i can tell of the jcraft website, this looks like it is the latest version available ? (0.1.55)
I am rebuilding the image without any changes yet. I also tried with the nightly built image from the development server and it exhibits the same issue. (4.0.0-devel-20200730+build.168 (zeus) apalis-imx8)

Dear @Edouard ,

Sorry I may have slightly overlooked the fact you are using BSP4.0. Unfortunately, we will never officially release this version because we want to move to an LTS version of Yocto (Dunfell). Therfore, please use BSP3.0 for now. The next stable BSP5.0 should be released in Q4 2020.

And if you face similar issues in BSP 3.0, please let us know here and we are glad to help you with that.

Thank you and Regards,
Janani

I run into the same issue with the failed algorithm negotiation after upgrading from BSP v3.0 to v5.1.0-devel.

It’s the same behavior for a iMX7D and a iMX8M SOM.

My Ubuntu 20.04.1 LTS uses OpenJDK 11 and in the file /usr/lib/jvm/java-11-openjdk-amd64/conf/security/java.security the setting crypto.policy is set to unlimited.

I also tried it under Windows 10 Pro 2004 with an freshly installed JDK 15.0.1 and Eclipse 2020-09 (4.17.0) and got the same error. When I use FileZilla or MobaXterm I get a connection immediatly.

With BSP v5.0.0 there’s also no difference …

Hi @Mowlwurf

Thanks for communicating this issue. We will look into this and come back to you.

Best regards,
Jaski

My workaround is adding the following to local.conf in our Yocto building environment and rebuilding the image. I also don’t find a solution from Java setting side.

PACKAGECONFIG_remove_pn-dropbear = " disable-weak-ciphers"

Thank you for your answer, this worked for me too.

I only had to add ‘gdbserver’ to IMAGE_INSTALL in the ‘tdx-reference-*’ images for a working debug session using ssh.

Hi @Mowlwurf

Perfect that it works. Thanks for the feedback.

Best regards,
Jaski